60223: Acronis Storage and Acronis Storage Gateway: how to clear FES address from Agent's cache

Symptoms

  1. You have changed your Acronis Storage 1.5 / Acronis Storage Gateway's external IP, DNS name, or port the service is listening on.
  2. You have successfully re-registered the storage to apply these changes to Acronis Backup Cloud.
  3. Backups for some clients are failing with the following error:
    Error code: 212
    Module: 161
    LineInfo: 0x0B320396ADFE3EA3
    Fields: {"IsReturnCode":"1","$module":"disk_bundle_vsa64_3917"}
    Message: Failed to find archive 'archivename'.
    ------------------------
    Error code: 1085
    Module: 3
    LineInfo: 0x8258202786770DDF
    Fields: {"$module":"disk_bundle_vsa64_3917"}
    Message: Failed to connect to XXX.XXX.XXX.XXX <<=  <OLD_IP_ADDRESS>

Cause

After changing the external IP, port, or DNS record, client machines may still have the old values cached. We recommend leaving the old IP/DNS in function for 2 weeks after making changes. In case the old address is no longer accessible, you need to clear the backup client cache manually.

Solution

Windows:

  1. Stop Acronis Managed Machine Service.
  2. Run Windows registry editor (regedit.exe).
  3. Remove the HKEY_LOCAL_MACHINE\SOFTWARE\Acronis\BackupAndRecovery\Settings\OnlineBackup\FesAddressCache key.
  4. Start Acronis Managed Machine Service.

Linux:

  1. Stop the MMS service:
    # systemctl stop acronis_mms
     
    If systemd is not available in your distribution, use:
    # /etc/init.d/acronis_mms stop
  2. Open the configuration file for editing:
    vi /etc/Acronis/BackupAndRecovery.config
  3. Locate the following part and remove it:
    <key name="FesAddressCache">
    ...
    </key>
  4. Save the file.
  5. Start the MMS service:
    # systemctl start acronis_mms
     
    Or:
    # /etc/init.d/acronis_mms start

MacOS:

  1. Stop the MMS service: open Terminal and execute the following string:
    $ sudo launchctl stop acronis_mms
  2. Open the configuration file for editing:
    $ sudo vi /Library/Application Support/Acronis/Registry/BackupAndRecovery.config
  3. Locate the following part and remove it:
    <key name="FesAddressCache">
    ...
    </key>
  4. Save the file.
  5. Start the MMS service: open Terminal and execute the following string:
    $ sudo launchctl start acronis_mms

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