Symptoms
Backup of virtual machines finishes with warnings:
Error code: 102
Module: 83
LineInfo: 0x3E00788FD9D77AD8
Fields: {"$module":"hv_srv_vsa64_2659"}
Message: Creating a crash-consistent snapshot of virtual machine 'XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX' because the creation of its application-consistent snapshot has failed.
------------------------
Error code: 138
Module: 83
LineInfo: 0xFB98212D12086BB3
Fields: {"$module":"hv_srv_vsa64_2659"}
Message: Failed to create the virtual machine snapshot (Machine: 'XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX'; Name: 'AcronisBackup').
Cause
There are multiple possible causes for this message:
- Operating system inside VM does not support application-consistent snapshots
- Malfunction of Hyper-V Integration Services/VMware tools
- Snapshot issues on VM
Solution
1) If you are backing up Linux virtual machines or virtual machines with dynamic disks on a Hyper-V host: application-consistent snapshot is naturally (by hypervisor itself) not supported for Linux virtual machines or virtual machines with Windows dynamic disks running on a Hyper-V host.
To prevent these warnings, as a workaround, disable the VSS for virtual machines backup option:
- Open the backup plan for editing.
- Click Backup options.
- Set Volume Shadow Copy Service (VSS) for virtual machines to disabled.
2) Make sure your Linux distribution is supported: see Supported Linux and FreeBSD virtual machines for Hyper-V on Windows Check each of the supported Linux distributions to find the one used in your environment and confirm whether "Live virtual machine backup" option applies to your Linux distribution, and make sure that Linux Integration Services (LIS) are installed inside VM.
3) If this warning appears during a backup of a Windows virtual machine without dynamic disks, make sure that either the latest Integration Services (for Hyper-V environment) or VMware tools (for ESX(i) environment) are installed inside the affected VM. For Windows Server 2008R2 you can use integration tools from Windows Server 2012R2.
4) For Hyper-V Server, issue could be in the logon and user rights assigned to service users inside Active Directory. Please see this Microsoft Support article for more information.
If the points above do not apply, follow Acronis Cyber Backup: virtual machine backup troubleshooting guide.
As a temporary workaround, you can disable the VSS for virtual machines backup option to stop the warnings until the root cause of the issue is found:
- Open the backup plan for editing.
- Click Backup options.
- Set Volume Shadow Copy Service (VSS) for virtual machines to disabled.