59843: Acronis Backup 12.5: backups to an encrypted managed vault fail with "Access to object 'Storage node' is denied" after upgrade from v.11.5

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Applies to:

Symptoms

  1. You have been using Acronis Backup Advanced 11.5.
  2. You have been backing up to an encrypted managed vault.
  3. You have upgraded to Acronis Backup 12.5 Advanced (using the in-place upgrade method)
  4. Backup fails with:
    Error code: 35
    Module: 39
    LineInfo: 0xAF0695FA9D426DEC
    Fields: {"$module":"storage_server_vsa64_6837"}
    Message: Location 'location' is not ready for use.
    ------------------------
    Error code: 46
    Module: 39
    LineInfo: 0xD2F435CBB7614B4B
    Fields: {"$module":"storage_server_vsa64_6837"}
    Message: Failed to open location 'location'.
    ------------------------
    Error code: 14
    Module: 39
    LineInfo: 0xD2F435CBB7614B0B
    Fields: {"$module":"storage_server_vsa64_6837"}
    Message: Access to object 'Storage node' is denied.
    ------------------------
    Error code: 269
    Module: 39
    LineInfo: 0xD2F435CBB7614B0A
    Fields: {"$module":"storage_server_vsa64_6837"}
    Message: The password is not set for location '{0}'.

Cause

Issue in the product.

Solution

The issue has been fixed in Update 1 (build 7641). Please update to the latest build.

As workaround without updating, do the following:

  1. Open Acronis web console.
  2. Navigate to Backups.
  3. Select the affected location.
  4. Provide login and password for the Storage Node and encryption key for the location. These credentials will then be stored in a secure credential store and allow backup plans to run properly.
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