59798: Acronis Cyber Protect Cloud, Acronis Cyber Backup: manual registration of backup agent fails with “Failed to encrypt data. The system cannot find the file specified”.

Last update: 31-05-2021

Symptoms

  1. You attempt to install Acronis Agent using the full installation package. Installation fails at 98%.
  2. Installation without registration is completed successfully.
  3. An attempt to register the agent manually fails with the following error:

Error 0x1350016: TOL: Failed to execute the command. Setting the registration server address in the backup service
| line: 0x8d165e86fb819595
| function: Tol::`anonymous-namespace'::MakeFailResult
| CommandID: BD897884-9F47-4DC0-BC02-DA8DA2BBBD48
| $module: mms_vsa64_3855
|
| error 0x1350016: TOL: Failed to execute the command. Setting the registration server address in the backup service
| line: 0x8d165e86fb819595
| function: Tol::`anonymous-namespace'::MakeFailResult
| CommandID: BD897884-9F47-4DC0-BC02-DA8DA2BBBD48
| $module: zmq_infra_vsa64_3855
|
| error 0x2760002: Cannot modify user profile.
| line: 0x8f84435ae6490414
| function: Msp::Agent::Commands::SetRegistrationServerAddressLogic::RunLogic
| $module: zmq_infra_vsa64_3855
|
| error 0x273000d: Access violation in module 'zmq_infra.dll' at line '0x8f84435ae6490414', executable: 'mms.exe'.
| line: 0xe839411589f18a1f
| function: AccessManagement::ProfileVaultComponent::AddAccountToSystemProfile
| $module: access_manager_vsa64_3855
|
| error 0x2730016: Failed to add account in user profile.
| line: 0x53cbdf900173a0cc
| function: AccessManagement::Impl::PersistentStorageLogic::AddAccount
| ResourceType: location
| ResourceAddress: crawford
| ProfileID: 23002D64-E4A6-493D-AA18-BEC82B304E98
| $module: access_manager_vsa64_3855
|
| error 0x26a0014: Failed to encrypt data.
| line: 0x36e942e8021f4b68
| function: Scrambler::EncryptData
| CurrentUserName: user\corp
| $module: security_core_vsa64_3855
|
| error 0xfff0: The system cannot find the file specified
| line: 0x36e942e8021f4b68
| function: Scrambler::EncryptData
| code: 0x80070002
| $module: security_core_vsa64_3855
 

Cause

Windows "Default" user profile got corrupted and therefore all profiles for newly created users on that machine also become corrupted.

Solution

Switch the “Default” user profile on the affected machine with one from another machine running same Windows version:

  1. Move all files from C:\Users\Default\ on the affected machine to a temporary folder.
  2. Copy all files from C:\Users\Default\ from another machine running same OS version and paste them to C:\Users\Default\ on the affected machine.
  3. Execute manual registration command again: