Symptoms
- You are providing backup service based on Acronis Cyber Protect Cloud through WHMCS.
- You create a backup plan for selling.
- You select Recurring Payment in Product Properties -> Pricing.
- Your customer purchases backup service.
- Processing order fails:
- opening invoice fails with:
Module AcronisBackupService: Error occured [2]: filemtime(): stat failed - accepting order manually fails and activity log shows this error:
Cannot get the email details. HTTP error code 404
- opening invoice fails with:
Cause
Administrator's credentials are not saved in order processing.
Solution
Use one of these workarounds:
- In WHMCS administrator panel, navigate to Setup -> General Settings -> Ordering. Check Tick this box to generate random usernames for services rather than use the first 8 letters of the domain check-box. With this option enabled, a valid random username is generated. Please note that this option can affect other modules.
- Provide administrator's credentials manually before accepting the order.