58190: Acronis Backup to Cloud 11.5/11.7: "You can manage only the subscription that is assigned to the current machine" Error

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Symptoms

1. You are deleting a cloud backup/archive:

  • of a machine that no longer exists (machine was decommissioned)
  • from the machine that doesn't have an activated subscription (i.e. you are deleting backup of machine A from machine B without any subscription assigned to it)
  • from the machine with a different subscription

2. Deletion fails with error:
Command 'Deleting archives' has failed.
Additional info:
--------------------
Error code: 61
Module: 309
LineInfo: 4a8728dc8a1c9510
Fields: $module : mms_vs_43994
Message: Command 'Deleting archives' has failed.
--------------------
Error code: 22
Module: 309
LineInfo: 8d165e86fb8195ff
Fields: TraceLevel : 1, $module : disk_bundle_vs_43994
Message: TOL: Failed to execute the command. The 'Deleting archives' command deletes the specified backup archives.
--------------------
Error code: 22
Module: 309
LineInfo: 8d165e86fb8195ff
Fields: TraceLevel : 1, $module : disk_bundle_vs_43994
Message: TOL: Failed to execute the command. The 'Deleting archives' command deletes the specified backup archives.
--------------------
Error code: 219
Module: 161
LineInfo: b320396adfe3ced
Fields: IsReturnCode : 1, $module : disk_bundle_vs_43994
Message: Failed to delete the archives.
--------------------
Error code: 59
Module: 161
LineInfo: 9e79958912ecdfd9
Fields: $module : disk_bundle_vs_43994
Message: You can manage only the subscription that is assigned to the current machine.
--------------------

Cause

Only the agent the subscription is assigned to has write access to backup data, therefore deletion fails.

Solution

  • If the machine, where the backups were created, still does exist and has Acronis agent installed, connect to that Agent and perform deletion.
  • If the machine is not available anymore, reassign the subscription to any spare machine and perform deletion: how to reassign subscription.

If the issue persists, take a screenshot of subscriptions in Reassign an already used subscription window and contact Acronis Customer Central with a reference to this article.

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