This is a known issue with Google Chrome browsers on Android devices.
Symptoms
When a webpage has multiple links to documents inside Acronis Access, navigating to Link A, and then Link B, and then again to Link A will cause Acronis Access to not process the request to Link A the second time.
Cause
This is due to the way Google Chrome handles external executions of its app. It counts every opened link in Acronis Access as a separate Chrome instance and by tapping the same link again, that app is only brought to the foreground since it is already running - skipping its startup steps, which would include the processing of the link.