57601: Acronis Backup Cloud: machine is offline in Backup Management Console

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Symptoms

After successful installation, the machine is offline in the Backup management console.

Possible causes

  1. Managed Machine Service is not running.
  2. A connectivity issue between the backup agent and cloud servers.
  3. Registry keys "MMSCurrentMachineID" and "InstanceID" do not match with IDs on the management server in Acronis cloud.

Solution 1

Make sure Acronis Managed Machine Service is running. If the service is stopped, the machine cannot communicate with the management server.

To check the status and start Acronis Managed Machine Service, do the following:

  • Windows: navigate to Windows services and check whether the Managed Machine Service is running: Start -> Search -> services.msc
  • Linux: open Terminal and execute under a superuser/root /etc/init.d/acronis_mms status
  • macOS: open Terminal and execute these commands to check services
    sudo launchctl list acronis_mms
    sudo launchctl list acronis_agent
    execute these commands to start services
    sudo launchctl start acronis_mms
    sudo launchctl start acronis_agent

Solution 2

Make sure all required ports are open. Otherwise, Acronis agent cannot communicate with the management server.

  • Windows: use the Connection Verification Tool to check connectivity. Review the output. If the tool reports a port is closed, open this port.
  • Linux: open Terminal and check whether required ports are open with the netcat command, for example:
    nc -zv baas.acronis.com 443
    If one or several of the listed ports are closed, open these ports.
  • macOS: use the Network Utility to check whether required ports are open (if you need help using the utility, see this article).

Solution 3

1. Open the backup management console, select the machine by clicking on it and check browser's address bar.

2. Note InstanceID and MMSCurrentMachineID. GUID between "phm." and "%40" is InstanceID, after "%40" is MMSCurrentMachineID:

3. Compare the values to the values on the machine:

Windows: navigate to HKEY_LOCAL_MACHINE\Software\Acronis\BackupAndRecovery\Settings\MachineManager and note the values of  "MMSCurrentMachineID" and "InstanceID".
For example:
"InstanceID"="480D99EA-A79E-4FF0-9AF2-CDB6DD1D09CD"
"MMSCurrentMachineID"="6D4FDB37-5DE0-43BF-A499-B5076B44E1F6"

Linux: open /etc/Acronis/BackupAndRecovery.config and note the values of  "MMSCurrentMachineID" and "InstanceID".
For example:
<value name="InstanceID" type="TString">
                "C6C54E65-D328-4B2F-ABB4-37BA50E98CAA"
            </value>
...
<value name="MMSCurrentMachineID" type="TString">
                "B7B3DD56-2F64-4CF2-AB82-FA1D440730F8"
            </value>

macOS: open /Library/Application Support/Acronis/Registry/BackupAndRecovery.config and note the values of  "MMSCurrentMachineID" and "InstanceID".

If they don't match, change to registy values on the Agent machine to the ones you found in step 2

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