57504: Acronis True Image: Filenames containing non-ASCII characters are not displayed correctly after download from Cloud

Symptoms

  1. You create a file-level backup to cloud. Some filenames in the backup contain non-ASCII characters like ä, ü, ó, ż, ę or others, Cyrillic letters, Japanese letters etc.
  2. You download the archive from the cloud.
  3. You unpack the archive.
  4. Filenames containing special characters are not displayed properly:

Cause

Decoding issue in Windows Explorer.

Solution

Unpack the archive with 7-zip - a free file archiver:

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