This article applies to old versions of the product: Storage 1.5 и Storage Gateway 1.7
Symptoms
Backup to Acronis Storage / Acronis Storage Gateway fails with error:
sslv3 alert certificate expired
Storage certificate is issued for a specific period of time and is automatically updated before it expires. It is stored locally on the Acronis Storage / Acronis Storage Gateway and Backup Agents.
To check certificate validity date:
1. Run the following command:
on a FES node of Acronis Storage:
# openssl x509 -in /mnt/fes/data/ca-certs/reg.crt -text
on Acronis Storage Gateway:
# openssl crl -in /etc/pki/tls/certs/Acronis/storage/reg.crl -noout -text
and
# openssl x509 -in /etc/pki/tls/certs/Acronis/storage/reg.crt -text
2. Check the validity or update dates:
Validity
Not Before: Aug 12 12:55:12 2015 GMT
Not After : Aug 11 12:55:12 2016 GMT
Update
Last Update: Aug 12 12:55:12 2015 GMT
Next Update: Aug 11 12:55:12 2016 GMT
3. If current date is not in this period, the certificate has expired.
Cause
Acronis Storage
Typical root cause is a connectivity problem when Acronis Backup Cloud servers are unreachable from Acronis Storage / Acronis Storage Gateway. As a result the certificate is not updated automatically.
Acronis Storage Gateway
Issue is known. Wrong permissions are set to folder /etc/pki/tls/certs/Acronis/storage during Acronis Storage Gateway registration and result into automatic certificate update failure.
Solution
See Acronis Backup Cloud: how to re-register Service Provider hosted storage.