56913: Acronis Files Connect: 'Change journal has wrapped, re-indexing Files Connect volumes' error

 

Symptoms

The following error message may appear in the Windows Event Log:

Change journal for volume <volume name> has wrapped, reindexing Files Connect volumes

Cause

When the search indexing feature is enabled, Files Connect devotes resources to watching and processing changes from the NTFS Change Journal, Windows’ internal log of all file system transactions. On servers with a very high rate of file system changes (particularly file creation and deletion), Files Connect may not be able to process these changes rapidly enough. If it falls far enough behind, this will trigger an automatic reindex of any volumes on a particular physical disk.

Solution

To increase the amount of resources Files Connect devotes to processing the Change Journal, Files Connect uses a non-refreshable registry value: “ChangeJournalReaderThreads”. This value must be between the default of 2 and a maximum of 5. Increasing this value (and restarting the service) can alleviate the reindexing issue.

The registry value can be created or edited by following the directions below:

 

  1. Go to Start>Run and enter regedit
  2. Navigate to the following folder: \HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ExtremeZ-IP\Parameters4\NonRefreshable
  3. Right click and select Edit> Create new> DWORD Value 
  4. Enter ChangeJournalReaderThreads and press OK.
  5. Doubleclick on the new key and enter the ValueData (from 2 to 5, inclusive)
  6. Click OK.

Since this is a non-refreshable value, the change will not take effect until the next time Acronis Files Connect starts up.

 

Tags: 

You are reporting a typo in the following text:
Simply click the "Send typo report" button to complete the report. You can also include a comment.
CAPTCHA
This question is for testing whether or not you are a human visitor and to prevent automated spam submissions.
2 + 2 =
Solve this simple math problem and enter the result. E.g. for 1+3, enter 4.