49568: Acronis Backup Advanced 11.7/11.5: Update of Acronis Management Server Fails with "'User' is not a valid login or you do not have permissions"

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Symptoms

  1. You are installing an update of Acronis Backup Advanced.
  2. Update fails with:
    Acronis Backup 11.5 Management Server 
    Code: 08356354 
    Line tag: 0x5538f731ab69496 
    Message: Failed to repair the database. 

    Suberror 
    Code: 01 
    Line tag: 0x39098ee09af00d2b 
    Message: An error occurs while executing SQL command: master..sp_addsrvrolemember @loginame = N'Domain\user', @rolename = N'dbcreator' 

    Suberror 

    Code: 08323089 
    Line tag: 0xc131f5921ff77449 
    Message: Query 'master..sp_addsrvrolemember @loginame = N'Domain\user', @rolename = N'dbcreator'' failed to execute. 

    Suberror 
    Code: 08338079 
    Line tag: 0xc131f5921ff77428 
    Message: 'Domain\user' is not a valid login or you do not have permission.

or

Message: "Failed to repair the database. 

Suberror 
Code: 08323088 
Line tag: 0xc131f5921ff773f4 
Message: Can not open ADO connection 30 times 

Suberror 
Code: 08327132 
Line tag: 0xc131f5921ff773f0 
Message: Cannot open database "acronis_cms_cards" requested by the login. The login failed."

Cause

Acronis Management Server user has a linked user on the SQL server. In case the machine was renamed, was excluded from the domain or has joined another domain or, the AMS user name was changed. However, the SQL server user is not updated automatically causing the conflict.

Solution

Scenario 1

Rename the SQL server user linked to the Acronis Management Server Service user.

  1. Connect to the Acronis instance with SQL Server Management Studio. (Start SQL Server in Single-User Mode if the user does not have enought priviliges on the SQL server.)
  2. Navigate to Security -> Logins
  3. Locate the user linked to the AMS service user (this user still has the old name).
  4. Right-click -> Rename
  5. Rename the user, it should match the current AMS service user.
  6. Start the update.

Scenario 2

  1. Go to Start -> Run -> Ssms.exe (run as Administrator).
  2. Choose the server with Acronis instance and click on “Connect”.
  3. Go to Security -> right-click on “sysadmin” role -> Properties. Click on “Add” and add this role to the user, under which you want to install update.
  4. Click on “OK”, close the console and install the update.

Scenario 3

(if the previous Scenarios fail with error – you do not have rights to save the changes or you have no installed SQL Management Studio)

  1. Create on the desktop a .txt file with following T-SQL-script in it
    Exec master..sp_addsrvrolemember @loginame = 'DOMAIN\USER',@rolename = 'sysadmin'
    (where DOMAIN\USER is the user, you want to grant the sysadmin role)
  2. Go to Start-Run-services.msc
  3. Find the service SQL Server (ACRONIS), change the Log on to Local System, stop the service.
  4. Stop Acronis Management Server Service as well.
  5. Go to Start -> Run -> cmd as Administrator
  6. Type in net start MSSQL$ACRONIS /m
  7. Type in the following command after
    sqlcmd -S <machine name>\ACRONIS -i <full path to the SQL script created in step 1>
  8. Close the cmd window after the script worked (the should be no output), restart SQL Server (ACRONIS), start Acronis Management Server Service.
  9. Start the installation file under Administrator and install the update

It is also recommended to use the same user you are logged in as Log On account for Acronis Management Server Service as he got the sysadmin role from previous steps. Please, check also that this user has proper rights to start the service as it is described here: http://www.acronis.com/en-us/support/documentation/AcronisBackup_11.5/#13699.html

 

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