47858: MassTransit Administrator Cannot Connect to Engine

Translate to:

Applies to:

Repair the database to fix the issue

Symptoms

When opening MassTransit Administrator, you receive the following error:

An error occurred with MassTransit:
Unable to connect to the MassTransit server
0004:0008

Cause

The service is not started to the database is damaged.

Solution

Try to start the MassTransit Service. If the service starts then reconnect from the Admin. If the service won’t start check the Event Viewer for errors regarding the MySQL tables. If there are problems with the tables, they can generally be resolved by a database repair. 

To do a database repair you should first backup your databases:

- and then do a repair: Repairing MySQL Tables

More information

See also MassTransit FAQ.

 

You are reporting a typo in the following text:
Simply click the "Send typo report" button to complete the report. You can also include a comment.
CAPTCHA
This question is for testing whether or not you are a human visitor and to prevent automated spam submissions.
2 + 3 =
Solve this simple math problem and enter the result. E.g. for 1+3, enter 4.