47228: Acronis Backup Advanced 11.5 for Active Directory: Backup Fails with "Failed to get information about SYSVOL"

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Applies to: 

Symptoms

  1. You are backing up your Domain Controller with a single-pass backup.
  2. Backup fails with:

Error code: 41
Module: 307
LineInfo: e6792a5ee190dda6
Fields: $module : agent_protection_addon_vs_38573
Message: Failed to execute the command.
--------------------
Error code: 54
Module: 482
LineInfo: 5c71ebf434f0c47a
Fields: $module : disk_bundle_vs_38573
Message: Failed to collect all of the data required for single-pass backup of Microsoft Active Directory.
--------------------
Error code: 3
Module: 555
LineInfo: 789ed4e56b18ea5f
Fields: $module : ad_agent_vs_38573
Message: Failed to get information about SYSVOL. Either this information is absent from Active Directory or the version of Active Directory is not supported. 

See solution 1 and 2.

or

Error code: 54 

Module: 482 
LineInfo : 5c71ebf434f0c47a 
Fields: $module : disk_bundle_vs_39029 
Message: Failed to collect all of the data required for single-pass backup of Microsoft Active Directory.
-------------------- 
Error code: 2 
Module: 555 
LineInfo: 789ed4e56b18ea6b 
Fields: $module : ad_agent_vs_39029 
Message: The required parameter «msDFSR-StagingPath» is not found in LDAP entry «CN=SYSVOL Subscription,CN=Domain System Volume,CN=DFSR-LocalSettings,CN=DC01,OU=Domain Controllers,DC=domain,DC=all,DC=com». 

See solution 2.

Cause

There are two possible causes:

  1. Domain controller machine is not present in Domain Controllers container in Active Directory: Users and Computers snap-in. See Solution 1.
  2. The SYSVOL directory is not specified in the Domain Controller properties. See Solution 2.

Solution

The issue has been fixed in Update 1 of Acronis Backup (Advanced) 11.7, please update to the latest build.

As workaround, you can use these solutions:

Solution 1

  1. On your Domain Controller start Active Directory: Users and Computers snap-in.

  2. Navigate to the container where Domain Controller machine is. If you don't know the exact location of the DC machine use "Find" under "Actions" menu.

  3. Right-click on the DC machine, click "Move" and choose Domain Controllers container. Click OK.

  4. Start backup. It should run successfully.

Solution 2

While backing up Active Directory Acronis Backup checks the following items:

DC= YOUR_DOMAIN_NAME > OU=Domain Controllers > CN=MACHINE_NAME_OF_PARTICULAR_DC (if you have more than one), then:

  • CN=DFSR-LocalSettings > CN=Domain System Volume > CN=SYSVOL Subscription where we look for msDFSR-RootPath and msDFSR-StagingPath
    or
  • CN=NTFRS Subscriptions > CN=Domain System Volume (SYSVOL share) where we look for frsRootPath and frsStagingPath. 

If any of the above cannot be found, backup fails.

  1. Start Active Directory Service Interfaces Editor (ADSI Edit) and connect to Default Configuration or Default Naming Context on your Domain Controller.
  2. Navigate to DC=<your_domain_name> > OU=Domain Controllers > CN=<DC_machine_name>.
  3. Navigate to:
    CN=DFSR-LocalSettings > CN=Domain System Volume > CN=SYSVOL Subscription
    or
    CN=NTFRS Subscriptions > CN=Domain System Volume (SYSVOL share)
  4. In CN=DFSR-LocalSettings > CN=Domain System Volume > CN=SYSVOL Subscription
    check msDFSR-RootPath and msDFSR-StagingPath.

    In CN=NTFRS Subscriptions > CN=Domain System Volume (SYSVOL share)
    check frsRootPath and frsStagingPath.

    The SYSVOL directory should be specified there, e.g.:

    Specify the paths to SYSVOL directory if they are not specified yet.

More information

Please contact Acronis Customer Central if you need assistance.

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