47126: Acronis Backup Advanced: Backup to Tapes Fails with "Incorrect function"

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Decrease HKEY_LOCAL_MACHINE\Software\Acronis\BackupAndRecovery\TapeLocation/WriteCacheSize by 2 (min.value 16384)

Symptoms

  1. You create a backup plan and select to store your backup on tapes.
  2. Alternatively you want to export a backup to tapes.
  3. Operation fails with error:
    Error code: 3
    Module: 329
    LineInfo: 1cd98aae889424f9
    Fields: $module : disk_bundle_tape_off_glx_pic_38351
    Message: Backup has failed.
    --------------------
    Error code: 1060
    Module: 1
    LineInfo: b43e776571144dec
    Fields: $module : disk_bundle_tape_off_glx_pic_38351
    Message: Failed to commit operations.
    --------------------
    Error code: 4
    Module: 7
    LineInfo: 9d2de1f088cbc55a
    Fields: $module : disk_bundle_tape_off_glx_pic_38351
    Message: Write error.
    --------------------
    Error code: 3
    Module: 4
    LineInfo: c41defba28f4d16f
    Fields: $module : storage_server_vsa64_38351
    Message: Error occurred while writing the file.
    --------------------
    Error code: 65520
    Module: 0
    LineInfo: bd28fdbd64edb8e0
    Fields: code : 2147942401, $module : storage_server_vsa64_38351
    Message: Incorrect function

Cause

There are two possible causes for the issue:

  • Default write operations cache set in Acronis Backup is too large for some tape devices' drivers. See Solution 1.
  • Tape device drivers were updated and the device needs to be recognised anew. See Solution 2.

Solution

Solution 1
Decrease write cache:

  1. Open the Windows registry editor (Start -> Run -> regedit.exe) and navigate to HKEY_LOCAL_MACHINE\Software\Acronis\BackupAndRecovery\TapeLocation
  2. Change value of DWORD WriteCacheSize to 131072. Ensure this value is set in Decimal system
  3. Restart Acronis Removable Storage Management service.
  4. Start backup.
  5. If it fails, reduce the WriteCacheSize value by 2 (to 65536, to 32768, to 16384, but not lower than 16384), restart ARSM service, try backup.

Solution 2
Let Acronis Backup recognize the device anew:

  1. In the tape management section select your machine.
  2. Click on Detect tape devices.

More information

Please contact Acronis Customer Central if you need assistance.

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