4695: Acronis Backup & Recovery 10 Management Server Hangs on "Adding the machine..."

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Operating Systems: 

Last update: 28-03-2011

Delete the Acronis Managed Machine Service (MMS) logs and Acronis Agent backup policies to resolve the issue

This article applies to:

  • Acronis Backup & Recovery 10 Advanced Server
  • Acronis Backup & Recovery 10 Advanced Server - Small Business Server Edition
  • Acronis Backup & Recovery 10 Advanced Workstation
  • Acronis Backup & Recovery 10 Advanced Server - Virtual Edition

Symptoms

  1. You are trying to add a new machine to Acronis Management Server;
  2. The operation hangs on Adding the machine...:

  3. At the same time, on the machine where the Acronis Agent is installed and which you are trying to add to the Acronis Management Server, the MMS.exe process starts consuming CPU and memory.

Cause

There is a considerable amount of the MMS service logs on the machine where the Agent is installed.

When trying to add the Acronis Agent to the Acronis Management Server, it tries to process all the logs and add the information to its database.

Solution

  • Stop Acronis Managed Machine Service on the machine with the Acronis Agent:
    • Hit Start-Run and type in services.msc;
    • Right-click on Acronis Managed Machine Service -> choose Properties -> set Startup type to Disabled -> and choose to Stop the service.
  • On the same machine, delete all the Acronis Agent logs by emptying the following folders:

    Windows 2000/2003/SBS/XP

    • \Documents and Settings\All Users\Application Data\Acronis\BackupAndRecovery\MMS\LogContexts\
    • \Documents and Settings\All Users\Application Data\Acronis\BackupAndRecovery\MMS\LogEvents\
    • \Documents and Settings\All Users\Application Data\Acronis\BackupAndRecovery\MMS\Outbox\

    Windows 2008/Vista or Windows 7

    • \ProgramData\Acronis\BackupAndRecovery\MMS\LogContexts\
    • \ProgramData\Acronis\BackupAndRecovery\MMS\LogEvents\
    • \ProgramData\Acronis\BackupAndRecovery\MMS\Outbox\
  • Start Acronis Managed Machine Service:
    • Hit Start-Run and type in services.msc;
    • Right-click on Acronis Managed Machine Service -> choose Properties -> set Startup type to Automatic -> and choose to Start the service;
  • Delete all backup policies of the Acronis Agent:
    • Connect Acronis Management Console to the Acronis Agent;
    • Delete all entries under Backup plans and tasks;
    • Empty the following folders:

      Windows 2000/2003/SBS/XP

      • \Documents and Settings\All Users\Application Data\Acronis\BackupAndRecovery\MMS\Policies\
      • \Documents and Settings\All Users\Application Data\Acronis\BackupAndRecovery\MMS\PolicyStatistics\
      • \Documents and Settings\All Users\Application Data\Acronis\BackupAndRecovery\MMS\TasksStorage\

      Windows 2008/Vista or Windows 7

      • \ProgramData\Acronis\BackupAndRecovery\MMS\Policies\
      • \ProgramData\Acronis\BackupAndRecovery\MMS\PolicyStatistics\
      • \ProgramData\Acronis\BackupAndRecovery\MMS\TasksStorage\
  • Run the following file:

    Windows 32 bit: \Program Files\Acronis\BackupAndRecovery\schedmgr.exe
    Windows 64 bit: \Program Files (x86)\Acronis\BackupAndRecovery\schedmgr.exe

  • Issue the following command:

    task zap

Adding the machine to the Acronis Management Server should now work fine.

More information

This is a rare case when the logs may grow because of some failing tasks generating numerous events. The behavior has been improved in the latest updates of Acronis Backup & Recovery 10 by introducing retention rules on the overall size of logs.

See also Acronis Backup & Recovery 10: Acronis Storage Node Is Unresponsive Due to Excessive Logs.

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