45551: Acronis Backup 11.5: Backup Fails with Error "There is no metadata for archive"

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Applies to:

Rename the metadata file to its standard name or recreate the metadata files.

Symptoms

  1. You create a backup plan to a managed vault.
  2. Backup fails with error like this:

Error code: 3
Module: 64
LineInfo: f440d05d16e0fd5b
Fields:  path : bsp://Server/vault#arl:/D9D6A983-33BC-41E9-855F-13D2C3CE772B/06C02D9C-5E6A-45BE-AB9B-7CBB36515095/3D7D45E6-62D0-4D81-B787-A9E3BFDE0C81, $module : disk_bundle_vs_37613
Message: Failed to open the archive for writing.
--------------------
Error code: 101
Module: 39
LineInfo: d2f435cbb7614e2c
Fields:  $module : storage_server_vsa64_37613
Message: There is no metadata for archive '3D7D45E6-62D0-4D81-B787-A9E3BFDE0C81' from vault 'vault'.
--------------------
Event code: 0x00400003+0x00270065

Cause

There are two possible reasons for this behavior:

(This issue has been fixed, please update to the latest build) Cause 1

Backup is created in silent mode and backup location runs out of space. User interactions are disabled in the silent mode, therefore the backup fails. In the vault .meta folder the archive metadata file keeps its temporary name like .tmp.6D3D45E6-00D0-4D81-B741-A9E3BFDE0C36.3D7D45E6-62D0-4D81-B787-A9E3BFDE0C81 and cannot be read during the next backup. This backup fails with the error mentioned above.

Go to Solution 1 to resolve this issue.

Cause 2

Folder .meta was manually deleted from the vault folder. Archive metadata contained in this folder is no more present for the backups and no further operations with the existing archives are possible.

Go to Solution 2 to resolve this issue.

Solution

Apply the solution according to the cause mentioned above.

Solution 1

    1. Free up space in the backup location.
    2. Navigate to the location of the vault.
    3. Open the .meta folder.
    4. Identify the metadata file of the archive mentioned in the error message.
    5. Rename the metadata file to its standard name, which you can see in the error message, e.g. 3D7D45E6-62D0-4D81-B787-A9E3BFDE0C81.

As a workaround you can create archive with another name.

Solution 2

    1. Detach the vault from the Storage Node
    2. Look for *.fdb file in the root folder of the vault, it was moved to this folder after the vault was successfully detached. Create a backup of this file and remove it from this folder. If the vault was successfully detached, but the *.fdb file is not present in the vault root, then go the the next step.
    3. Attach the vault back to the Storage Node.

Vault metadata will be recreated and vault backups will be re-indexed according to the vault content.

More information

Issue described in Cause 1 has been fixed.

If the steps provided above do not resolve the issue, please collect the following infromation and contact Acronis Customer Central:

  1. .meta folder of the vault.
  2. Collect System Report of the machine, where Acronis Storage Node is installed, with the Acronisinfo Utility.

 

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