Make sure the correct user accounts with the required permissions are used
This article applies to:
- Acronis Backup Advanced 11.5 (Acronis Backup & Recovery 11.5)
Symptoms
An attempt to perform any of the following:
- Browse of databases in the backup tree;
- Database level backup;
- Mailbox level backup.
Fails with the error:
Code: 5,963,806(0x005B001E)
LineInfo: 0xE45D4302DE4B88BE;
Module: arx_agent_vs_37741
Message: Failed to browse Microsoft Exchange Server.
Code: 5,963,782(0x005B0006)
LineInfo: 0x9F4D875A39EF5AB8;
Module: arx_agent_vs_37741
Message: Cannot connect to Microsoft Exchange Server.
Code: 20,250,646(0x01350016)
LineInfo: 0x8D165E86FB8195FF;
Module: exchange_management_vsa64_37741
Message: The Exchange management operation has failed.
Code: 5,964,835(0x005B0423)
LineInfo: 0xACF6DC4C960B8E1B;
Module: exchange_management_vsa64_37741
Message: The Exchange management operation has failed.
Code: 5,964,861(0x005B043D)
LineInfo: 0x2A578575733B311C;
Module: exchange_management_vsa64_37741
Message: An error has occurred while getting the configuration of the Exchange organization.
Code: 5,964,777(0x005B03E9)
LineInfo: 0x8DE328702E57F8AB;
Module: exchange_management_vsa64_37741
Message: A generic COM error of the PowerShell adapter.
Code: 5,964,778(0x005B03EA)
LineInfo: 0x8DE328702E57F385;
Module: exchange_management_vsa64_37741
Message: PowerShell error details: Value cannot be null.
*Parameter name: parameters*
at System.Management.Automation.Internal.PipelineProcessor.SynchronousExecuteEnumerate(Object input, Hashtable errorResults, Boolean enumerate)
at System.Management.Automation.Runspaces.LocalPipeline.InvokeHelper()
at System.Management.Automation.Runspaces.LocalPipeline.InvokeThreadProc()
Cause
The user account under which you are trying to perform the operation does not have enough privileges.
Solution
Make sure the correct user accounts with the required permissions are used as described in Acronis Backup Advanced 11.5: Necessary User Accounts to Back Up Microsoft Exchange Server.
Clear the credentials cache in Acronis Management Console:
Open Management Console -> Click "Options" -> Click "Console options"-> Select "Credentials cache"-> Click "Clear credentials cache". Restart Management Console.
If the correct user accounts are used but the issue persists, please do one the following:
After adding the necessary rights, restart the Acronis Managed Machine Service:
- Hit Start-Run -> services.msc
- Right-click on Acronis Managed Machine Service and click Restart.
More information
See also Acronis Backup 11.5.