During an update or an upgrade the default value of the setting "Number of Simultaneous VM Backups" can become 0. As a result, machine backups cannot be performed
Symptoms
- Acronis Backup & Recovery 10/11/11.5 is upgraded or updated remotely to Version 11.7 or a newer build;
- You are trying to run older backup plans which are still in the list;
- After an update or an upgrade all backup plans for the machine backup fail immediately after the start with an error in the logs similar to:
ProtectCommand: Failed to execute the command.
Additional info:
--------------------
Error code: 41
Module: 307
LineInfo: e6792a5ee190dda7
Fields: $module : agent_protection_addon_vs_32322
Message: ProtectCommand: Failed to execute the command.
--------------------
Error code: 29
Module: 307
LineInfo: d63b333701123473
Fields: $module : agent_protection_addon_vs_32322
Message: LaunchBackupCommand: Failed to execute the command.
--------------------
Cause
During an update or an upgrade the default value of the setting Number of Simultaneous VM Backups can become 0, but you will not see it in GUI of the product.
As a result, machine backups cannot be performed.
Solution
The issue will be fixed in the future updates.
As solution please use the following workaround:
- In the Acronis Management Console uncheck Options -> Default backup and recovery options -> Default Backup options -> Simultaneous VM Backups and press OK;
- Go to the same page again, check Simultaneous VM Backups and enter 2 in the Number of simultaneous backups field. Press OK.
Now all freshly created backup plans will run flawlessly.
To use the already existing plans:
- Export backup plan as an XML file (better to delete this old backup plan after that, so that not to confuse them);
- Open the exported XML file in a text editor (e.g. Notepad);
- Search for the following section:
</file_level_backup_snapshot>
<simultaneous_backups>
<backups_number>
0
</backups_number>
</simultaneous_backups> - Set 2 instead of 0, save XML file;
- Import this file as a backup plan in Acronis Backup
It is recommended to delete the old backup plan, so that not to confuse them
More information
Please contact Acronis Support if you need assistance.