Try disabling write caching for the USB drive to solve the issue
This article applies to:
- Acronis True Image Home 2011
- Acronis True Image Home 2010
- Acronis True Image Home 2010 Netbook Edition
- Acronis True Image Home 2009
- Acronis True Image 11 Home
- Acronis True Image 10.0 Home
- Acronis Backup & Recovery 10 Advanced Server
- Acronis Backup & Recovery 10 Server for Windows (Standalone)
- Acronis Backup & Recovery 10 Advanced Server - Small Business Server Edition
- Acronis Backup & Recovery 10 Advanced Workstation
- Acronis Backup & Recovery 10 Workstation (Standalone)
- Acronis Backup & Recovery 10 Advanced Server - Virtual Edition
- Acronis True Image Echo Enterprise
- Acronis True Image Echo Server for Windows
- Acronis True Image Echo Workstation
- Acronis True Image 9.1 Enterprise Server
- Acronis True Image 9.1 Server for Windows
- Acronis True Image 9.1 Workstation
Symptoms
- You are trying to backup to a USB drive;
- The backup operation fails with the following error messages:
Device is not ready
Failed to create volume snapshot
Cause
USB drive write caching is enabled (Optimize for performance). When write caching is enabled, the USB drive may fail to initialize in time when Acronis product accesses it. As a result, the product will error out with Device is not ready.
Solution
Disable write caching for the USB drive:
- Right-click the My Computer icon and then click Manage;
- Click the Device Manager icon;
- Click the plus (+) sign next to Disk Drives;
- Double-click the USB hard drive string:
- Click the Policies button then click the Optimize for quick removal radio-button and click OK:
More information
See also Multiple "Failed to read from sector..." Error Messages During Partition Analysis or Backup.
If the issue persists, please contact Acronis Support with a reference to this article.