39719: MassTransit 5.1 and 6.0 Database Backup Procedures for Mac OS X

Translate to:

Applies to:

Summary:

The article describes how to configure and use the MySQL Administrator application for Macintosh in order to automate the backup of MassTransit Professional, Enterprise, Premier and Standard server Databases.

Description:

The MySQL Administrator application is used to control and configure many aspects of the databases that MassTransit uses for file transfer operations. One of the more powerful and often overlooked features of the administrator is the ability to schedule automated backups of the MassTransit databases. At a specified interval, the Administrator will make complete copies of the MassTransit data, creating a .SQL file containing all database contents. In the event that database recovery is necessary, the contents of this .SQL file may be imported through a simple restoration process via the same Administrator tool.

 

Database Backup Process:

 

  1. Launch the MySQL Administrator tool.
  2. A dialog box will appear, prompting you to enter the Server Host, Username, and password.
    1. Server Host is usually localhost, or the IP address of the server that is running both MySQL Server and MassTransit Server.
    2. The username and password fields should be populated with the MassTransit MySQL user information that was specified at initial installation time.
  3. Once the MySQL Administrator tool has launched, click on the Backup option which appears in toolbar.
  4. In the right-hand window pane, three tabs should appear: Project, Advanced Options, and Schedule.
  5. Make sure that the Project tab is selected, and then click the Plus Sign button located underneath the Backup Projects window.
  6. Next, provide the Project Name field with a name for the MassTransit Database backup project. For example, MT_Backup.
  7. Then, under the Schemas column, select mtdatabase, which is your MassTransit data schema, followed by the > button.
  8. The mtdatabase schema should now appear to the left, within the Backup Content window.  Click to create a check mark on the little box next to the disk icon.  *** If this is not done, the database tables will not be selected and your backup will not contain your data.
  9. Next, select the Advanced Options tab to the right of the Project tab.
  10. Select the Lock All Tables and Backup Selected Schema Completely options if they are not already selected.
  11. Within the Output File Options window, make sure that SQL File is selected in the Backup Type pulldown menu.
  12. Now, select the Schedule tab, next to the Advanced Options tab.
  13. Click the Do not schedule backup pulldown menu to schedule your backup.  Choose to Execute this profile daily, Execute this profile weekly or Execute this profile monthly.
    1. If you choose daily, a box will appear to type in the desired time.
    2. If you choose weekly, click the day of the week you wish to execute your backup and enter the time in 24 hour military format.
    3. If you choose monthly, enter the day(s) you want your backup to execute, and then the time in 24 hour military format.  NOTE: Group Logic recommends greater frequency than just once monthly, as database updates may miss capture.
  14. Within the Target Directory field, select a directory in which you want your backup .SQL files are stored. NOTE: It is highly recommended that the location specified here be a drive or volume other than the volume that which contains your “live” MySQL data and MassTransit installation. This is to insure that backup data is not lost in the event of storage hardware failure.
  15. Within the File Name Prefix field, provide a name (i.e. MTBackup) for your database backup files.
  16. Under the Connection Name pulldown, leave the default.  This parameter is gleaned from your defined MassTransit connection information.  You should not need to change this.
  17. Lastly, click the Schedule button to schedule your automated backup.  For those familiar with the Unix cron utility, this will appear in the logged in user’s crontab.
  18. Click the Start Backup button to ensure your backup project is configured correctly.  Check to make certain the backup files are placed where you configured them in item # 14.  If the initial backup runs without errors, you have now successfully configured your MassTransit database backup.
  19. After successful configuration, the backup project that you have just created should appear under the Backup Projects column, in the left window pane.

Database Restoration Process:

  1. Launch the MySQL Administrator tool.
  2. A dialog box will appear, prompting you to enter the Server Host, Username, and password.
    1. Server Host is usually localhost, or the IP address of the server that is running both MySQL Server and MassTransit Server.
    2. The username and password fields should be populated with the MassTransit MySQL user information that was specified at initial installation time.
  3. Once the MySQL Administrator tool has launched, click on the Restore option which appears in the toolbar.
  4. Click the Choose File... button and select a backup file.
  5. Make sure that utf8 is set in the Character Set pulldown menu and click on the Open button.
  6. Check the Create schemas if necessary checkbox.
  7. Select the Selection and expand the selection to make sure all of the tables are selected.
  8. Click on the Start Restore button.

 

Tags: 

You are reporting a typo in the following text:
Simply click the "Send typo report" button to complete the report. You can also include a comment.
CAPTCHA
This question is for testing whether or not you are a human visitor and to prevent automated spam submissions.
10 + 8 =
Solve this simple math problem and enter the result. E.g. for 1+3, enter 4.