39628: Acronis Files Connect: Performance issues when Mac OS X client is unable to read .DS_Store file

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Operating Systems: 

Last update: 18-04-2018

Symptom:

Mac OS X Client Symptoms:

  • Slow browsing on a specific Volume or folder
  • Finder may hang on a specific Volume or folder
  • Mac OS may hang on a specific Volume or folder

Server Symptoms:

  • Server performance degrades when a single Mac OS X client is logged onto an Acronis Files Connect (formerly ExtremeZ-IP) Volume.
  • CPU spikes and high network traffic even though the client appears to be idle.

Steps to Reproduce:

  1. Deny read and write and delete access to .DS_Store files at the root of a network Volume or inside a folder within a share that the user account otherwise has write permissions for.
  2. Navigate to the folder using macOS Finder.
  3. Examination of packet capture of the conversation between client and server reveals millions of read/delete requests per hour for .DS_Store files.

Cause:

By default, macOS Finder will read/write/create .DS_Store files on network Volumes. If for some reason Finder is not able to read an existing .DS_Store file, on a share that is otherwise writeable, perhaps due to lack of permissions, or perhaps becuase the file is corrupt,  Finder will attempt to delete and recreate this file. Without the proper permissions, Finder can get caught up in an endless loop where it will issue millions of read/delete requests per hour. This unexpected behavior can degrade performance on both the client and server.

Workaround:

There are two options available to work around this problem.

  1. From the Windows Server, confirm all  user accounts have read permissions on all .DS_Store files when they have write permissions on the share (check permissions via the Security tab - not the Sharing tab).
  2. Disable .DS_Store file creation over network connections (full instructions on how to do this can be found from Apple here) and remov e all existing .DS_Store files from the server.  For this option, the workaround must be performed on each Mac client for each user account. It should be noted that .DS_Store files contained within folders that are copied to the server will be copied to the server as well, so it may be neccesary to schedule a task to remove .DS_Store files from the server periodically.

Fix:

This issue has been reported to Apple

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