33791: Acronis Backup for VMware: E-Mail Notification Failure Troubleshooting

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Last update: Wed, 2015-04-01 08:02

Either use a web browser different from Internet Explorer to access the Web Console to fix the issue, or troubleshoot the network issues/investigate the particualr SMTP server configuration

This article applies to:

  • Acronis vmProtect 6
  • Acronis vmProtect 7
  • Acronis vmProtect 8
  • Acronis Backup for VMware (Acronis vmProtect) 9

Symptoms

You connect to Acronis vmProtect Web Console using some Internet browser;

You are trying to set up an E-mail notification (for example in Configure->Backup Settings->Notifications->E-mail) to be sent through some SMTP server.

As a result the E-mail notification fails while testing and also in the planned task upon execution:

An error has occurred while executing command 'send_test_email_message'
An error has occurred while sending the test message.
Failed to send the message from 'example@email.com' to 'example2@email.com' (SMTP '192.168.1.1:25').

(!) The above errors are common (i.e. appear in any case if notifications fail), while the last error in the error stack identifies the exact reason for e-mail notification failure and may vary:

1) Authentication has failed.

OR

2) The server cannot accept DATA command.

OR

3) The mail server is unknown.

OR

4) Fatal error has occurred while reading from the socket.

OR

5) Mail server has rejected conforming to RFC.

OR

6) The server cannot accept the sender.

OR

7) The server has rejected the mail.

OR

8) Failed to connect to the mail server.

In rare cases test notifications work, but planned are not sent. Please see the solution section.

Cause

There is one known issue with e-mail notifications related to Acronis vmProtect 7 (it's fixed in vmProtect 8): Internet Explorer automatically adds a space symbol to the user name field. This causes the E-mail notification to fail with Authentication has failed. error.

All the other errors are related to the specifics of the setup of the SMTP server specified or by failures of name resolution in particular network. Please refer to recommendations for each error in the Solution section and detailed description of the email notification format in the More Information section.

Solution

1) Authentication has failed.

  • If you are using Acronis vmProtect 7 then as a workaround, please use any other Web Browser (i.e. Firefox, Chrome, Opera, etc.) instead Internet Explorer. For final solution please upgrade to Acronis vmProtect 8.
  • If the above doesn't help then this means that you have specified wrong username or password for connection to SMTP server. If your SMTP server accepts blank passwords please check Acronis vmProtect 7: Setting up E-Mail Notifications Through Microsoft Exchange Server 2007

2) The server cannot accept DATA command.

  • This error is returned from the SMTP server typically when the SMTP server is unable to resolve the IP of Acronis vmProtect Agent (Windows Agent or Virtual Appliance) to hostname. This requirement is applicable to 'sendmail' SMTP server for example. You can add some fake hostname for Acronis vmProtect Agent into /etc/hosts file on the SMTP server side and this should resolve the issue.

3) The mail server is unknown.

  • The address of the mail server could not be resolved to IP address. Try specifying the IP address of the SMTP server instead of the hostname.

4) Fatal error has occurred while reading from the socket.

  • This error is returned when the SMTP server rejects the first packet sent from Acronis vmProtect Agent and therefore the Agent receives an empty reply. This means that the validation of username/password has not even started at this stage. The most typical reason is that the IP of Acronis vmProtect Agent is declined by SMTP server firewall. Please consult with your SMTP server administrator to ensure that it doesn't block the requests from Acronis vmProtect Agent IP address.
  • Another possible reason is that the specified IP address of the SMTP server is actually referring to machine where there is no SMTP server installed.

5) Mail server has rejected conforming to RFC. There can be several reasons for this error, see listed below:

  • This error is returned when after connection to SMTP server an error occurred which rejects further actions. You should check the logs of the SMTP server and see if there are any errors related to the e-mail notification sending attempt.
  • The responce from SMTP server to HELO request has returned an error. You should check the logs of the SMTP server and see if there are any errors related to the e-mail notification sending attempt.
  • After switching to TLS encryption the responce to HELO request has retruned an error. Try disabling the encryption (TLS->SSL or disable it) and if this doesn't work then you should check the logs of the SMTP server and see if there are any errors related to the e-mail notification sending attempt.

6) The server cannot accept the sender.

  • The SMTP server returned an error in responce to MAIL FROM request. You should check the logs of the SMTP server and see if there are any errors related to the e-mail notification sending attempt.

7) The server has rejected the mail.

  • The SMTP server returned an error in responce to DATA request which sends the actual e-mail body. You should check the logs of the SMTP server and see if there are any errors related to the e-mail notification sending attempt.

8) Failed to connect to the mail server.

  • This error indicates that the connection has been established, however the SMTP server rejects it. You should first of all check the firewall settings, i.e. that the vmProtect Agent is able to contact the SMTP server at the specified port (25 by default).
  • An error occurred while trying to switch to TLS encryption (if server supports it). You should check the logs of the SMTP server and see if there are any errors related to the e-mail notification sending attempt.

9) Test notifications work, but planned are not sent.

  • The only difference between test and planned notifications are attachments, test notifications do not have attachments. Therefore you should set up your SMTP server to allow attachments.

If none of the solutions help, please collect Windows System Information File, screenshots of all the E-mail settings and a PCAP log (see Collecting PCAP Logs).

More information

The above solutions while covering most of the issues may not be applicable to 100% cases (since there are a lot of possible SMTP server configurations which all have their own specifics), so you find any additional tips for configuring specific SMTP servers please leave a feedback under this article with the described solution, so that we can update it.

For e-mail notifications Acronis products (including Acronis vmProtect, Acronis Backup and Recovery, Acronis True Image Home) are using a part of 'libsmtp 0.8.5' library (http://libsmtp.berlios.de). There are no 3rd party SMTP agents used (such as postfix or sendmail). The library supports direct SMTP connection in compliance with RFC 822.

Common requests scheme:

1. EHLO request is sent to SMTP server and if it doesn't support it (responce with code >= 300) then there is HELO request sent
2. Authentication (AUTH LOGIN command).
3. The address of the sender (MAIL FROM).
4. The recipient address (RCPT TO).
5. The text body (DATA).
6. The end of message (QUIT).

See also:

 

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