33029: Acronis Backup Advanced: Cannot Browse the Mailbox Contents in a Database Backup or Recover Mailbox Items from This Backup to PST Because the Exchange Libraries for ESE are Not Found or Have Another Version

Translate to:

Operating Systems:

If the database backup is stored in a managed vault, copy the necessary libraries from a machine with Microsoft Exchange Server to the storage node that manages this vault. If the database backup is stored in a centralized unmanaged vault, copy them to the management server. The version of Microsoft Exchange Server on the machine must be the same as the version of Microsoft Exchange Server, the data of which is backed up

Symptoms

When you want to:

  • Browse the contents of a mailbox or a public folder in a database backup. And you try to browse the items, the metadata of which was not collected during backup because a lesser level of detail had been set in the Metadata collection option.
  • Recover mailboxes or public folders from a database backup to PST files.

And the backup is stored in:

  • A vault managed by a storage node (a centralized managed vault).
  • An unmanaged vault which is accessed via a management server (a centralized unmanaged vault).

And the storage node or the management server has:

  • No Microsoft Exchange Server installed.
  • Another version of Microsoft Exchange Server which was installed after the backup had been made.

The following error message occurs: "Cannot obtain the backup contents because the required Exchange libraries for Extensible Storage Engine (ESE) are not found. See Acronis Knowledge Base for more details."

Cause

In the cases described in the Symptoms section, Acronis Backup has to open the respective databases and apply transaction logs directly from the backup to access the mailbox or public folder objects. The product requires the Exchange libraries for Extensible Storage Engine (ESE) to work with the backed up databases and transaction log files. However, these libraries are missing or have a different version on the storage node or the management server.

Solution

Take the necessary libraries from a machine with Microsoft Exchange Server and copy them to:

  • The storage node that manages the vault in which the backup is stored.
  • The management server that accesses an unmanaged vault in which the backup is stored.

(!) The version of Microsoft Exchange Server on the machine must be the same as the version of Microsoft Exchange Server, the data of which is backed up.

The required libraries are listed in the table:

Exchange version in the database backup Libraries Default location
Microsoft Exchange Server 2003

ese.dll
exchmem.dll
exosal.dll
jcb.dll

%PROGRAMFILES%\Exchsrvr\bin
ntlsapi.dll %SystemRoot%\system32
Microsoft Exchange Server 2007

ese.dll
exchmem.dll
jcb.dll

%PROGRAMFILES%\Microsoft\Exchange Server\bin
Microsoft Exchange Server 2010

ese.dll
esebcli2.dll
store.exe

%PROGRAMFILES%\Microsoft\Exchange Server\V14\bin
Microsoft Exchange Server 2013

ese.dll

%PROGRAMFILES%\Microsoft\Exchange Server\V15\bin

msvcr110.dll

%WINDIR%\system32
Microsoft Exchange Server 2016

ese.dll

%PROGRAMFILES%\Microsoft\Exchange Server\V15\bin

msvcr110.dll

msvcp110.dll

%WINDIR%\system32

Copy the libraries to the following folder on the storage node or the management server. If the folder ESE does not exist, please create it:

  • In Windows Vista/7/8/8.1/10/2008/2008R2/2012/2012R2/2016: %PROGRAMDATA%\Acronis\ESE
  • In Windows XP/2003: %ALLUSERSPROFILE%\Application Data\Acronis\ESE

(!) To work with Exchange 2007 database backups:

  • 64-bit version of Windows must be installed on the storage node or the management server.
  • Microsoft Visual C++ 2005 Redistributable Package (x64) must be installed on the storage node or the management server.

(!) To work with Exchange 2010 database backups:

  • 64-bit version of Windows must be installed on the storage node or the management server.
  • Microsoft Visual C++ 2008 Redistributable Package (x64) must be installed on the storage node or the management server.

(!) To work with Exchange 2013 database backups:

  • 64-bit version of Windows must be installed on the storage node or the management server.

(!) To work with Exchange 2016 database backups:

  • 64-bit version of Windows Server 2012/2012R2/2016 must be installed on the storage node or the management server.

After browsing the mailbox or public folder contents, these libraries may stay in use by the storage node or the management server for about 15 minutes. Therefore, you will not be able to delete them from the machine.

More information

Feel free to contact Acronis Customer Central with the reference to this article if you have any questions or issues.

Tags: 

You are reporting a typo in the following text:
Simply click the "Send typo report" button to complete the report. You can also include a comment.
CAPTCHA
This question is for testing whether or not you are a human visitor and to prevent automated spam submissions.
9 + 8 =
Solve this simple math problem and enter the result. E.g. for 1+3, enter 4.