30885: Acronis Backup 11.5/11: Installation Fails on RHEL 3

use Google Translate

Install an older version of dkms and rebuild SnapAPI

This article applies to:

  • Acronis Backup 11.5 (Acronis Backup & Recovery 11.5)
  • Acronis Backup & Recovery 11 (Linux)

Symptoms

  1. You are attempting to install an Acronis Agent for Linux on RHEL 3;
  2. The installation finishes with warnings similar to the following one:

    Failed to build SnapAPI module

Cause

RHEL 3 does not support the  =~ operator in dkms.

Solution

To fix the issue in Acronis Backup 11.5 (Acronis Backup & Recovery 11.5), do the following:

  1. Install all the necessary components as described in Creating the SNAPAPI Module in Acronis Backup Software for Linux;
  2. Install an older version of dkms and rebuild the SnapAPI modile using the following instructions:
    wget http://linux.dell.com/dkms/permalink/dkms-2.0.16-1.noarch.rpm
    rpm -U dkms-2.0.16-1.noarch.rpm --force
    dkms ldtarball --archive /usr/lib/Acronis/kernel_modules/snapapi-0.7.64-all.tar.gz
    dkms {build,install} -m snapapi -v 0.7.64

To fix the issue in Acronis Backup & Recovery 11, do the following:

  1. Install all the necessary components as described in Creating the SNAPAPI Module in Acronis Backup Software for Linux;
  2. Install an older version of dkms and rebuild the SnapAPI modile using the following instructions:

    wget http://linux.dell.com/dkms/permalink/dkms-2.0.16-1.noarch.rpm
    rpm -U dkms-2.0.16-1.noarch.rpm --force
    dkms ldtarball --archive /usr/lib/Acronis/kernel_modules/snapapi-0.7.62-all.tar.gz
    dkms {build,install} -m snapapi -v 0.7.62

More information

Please contact Acronis Customer Central if you need assistance.

 

Tags: