The "Log on as a service" right failed to be automatically added to the user under which you are trying to install
This article applies to:
Acronis Backup 11.5 (Acronis Backup & Recovery 11.5)
Acronis Backup & Recovery 11
Symptoms
You try to install Acronis Backup.
Installation fails with the following error:
Error Code: 0x00624E29+0x00D281F5 Error Message: Installation error.
Cause
There are two possible causes:
The name of the machine on which you are trying to install is longer than 15 characters. NetBIOS does not support this. Hence, the Log on as a service right cannot be automatically assigned to the user during installation. As a result, the installation fails.
The Log on as a service right failed to be added automatically to the user under which you are trying to install because of an unidentified reason.
Solution
If the name of the target machine is longer than 15 characters, rename it so that the name is shorter than 15 characters. This will allow the product to assign the Log on as a service right automatically to the user during the installation. The installation will then succeed.
If the name of the machine is not the issue, then make sure the user under which you are trying to install has the Log on as a service right:
If the target machine is not part of a domain:
Edit the Local Security Policy on the target machine:
Go to Start - > Control Panel -> Administrative Tools -> Local Security Policy ;
Browse down to Local Policies -> User Rights Assignment -> and find Log on as a service policy;
Double click on this policy and click on Add User or Group ;
Click Advanced ;
Click on Locations and make sure your local machine is selected as the location to look for the users;
Click OK, then click Find now and select the user under which you are trying to install:
Click OK several times to finish applying the policy.
(!) If the Add User or Group button is grayed out, then it means that the machine is a part of the domain, and the Log on as a service policy is defined via domain security settings, e.g.
In this case, please see the If the target machine is part of a domain or If the machine is a part of a domain and it is a domain controller of this article.
Restart Acronis Agent services:
Go to Start -> Run -> services.msc
Right-click on the following Acronis services, and click on Restart :
Acronis Managed Machine Service
Acronis Remote Agent
Acronis Scheduler2 Service
If the target machine is part of a domain:
Ensure that the Log on as a service right is added to the necessary accounts in the Domain Security Policy:
On the domain controller go to Start -> Control Panel -> Administrative Tools -> Domain Security Policy
Browse down to Local Policies -> User Rights Assignment -> and find Log on as a service policy:
Double click on this policy, enable the box Define these policy settings and click on Add User or Group :
Type in the account name and click OK ;
(!) For the proper functioning of Acronis Storage Server and Acronis Management Server, you need to add to this policy the accounts under which these components were installed and under which their services are running; by default it is ASN user and AMS user – or any alternative domain administrator user if during the installation you have chosen to use the existing domain administrator account.
Click OK when all the users are added:
The updated policy must be applied to the domain members: either wait for some time defined for your domain – for the domain policy to be refreshed and applied to all machines; or force domain policy update to be applied immediately on a particular domain machine:
Go to Start -> Run -> cmd
Execute the command:
gpupdate /force
Restart Acronis Agent services:
Go to Start -> Run -> services.msc
Right-click on the following Acronis services, and click on Restart :
Acronis Managed Machine Service
Acronis Remote Agent
Acronis Scheduler2 Service
If the machine is a part of a domain and it is a domain controller:
Ensure that the Log on as a service right is added to the necessary accounts in the Domain Controller Security Policy:
On the domain controller go to Start -> Control Panel -> Administrative Tools -> Domain Controller Security Policy
Browse down to Local Policies -> User Rights Assignment -> and find Log on as a service policy
Double click on this policy, enable the box Define these policy settings and click on Add User or Group
Click Browse -> Advanced
Click on Locations and make sure your domain is selected as the location to look for the users
Click OK, then click Find now and select the user under which you are trying to install from the list.
Restart Acronis Agent services:
Go to Start -> Run -> services.msc
Right-click on the following Acronis services, and click on Restart :
Acronis Managed Machine Service
Acronis Remote Agent
Acronis Scheduler2 Service
Having added the Log as a service right to the user on the target machine, reattempt the installation under the same user.
More information
If you need assistance, please contact Acronis Support .