An attempt to connect to an Acronis Agent fails with "Active Directory is not available for the specified user. Cannot create MAPI profile. Probably, the user does not have a mailbox or Microsoft Exchange MAPI and CDO are probably out of date."
This article applies to:
- Acronis Recovery for Microsoft Exchange
The operating system is:
- Windows Server 2008
Symptoms
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From Acronis Management Console you are trying to connect to an Acronis Agent on Windows Server 2008;
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The connection fails with the following error message:
Active Directory does not available for the specified user.
Cannot create MAPI profile. Probably, the user does not have a mailbox or Microsoft Exchange MAPI and CDO are probably out of date.In the log file of Acronis Recovery for Microsoft Exchange there is the following error message:
event code="65520" id="3" level="4" line_tag="0xBD28FDBD64EDB8B6" message="The system returned error: `Logon failure: the user has not been granted the requested logon type at this computer (1,385)`." module="0" time="1249372498"
Cause
The Log on as batch job policy does not have enough user rights to allow the connection.
Solution
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On the machine where the Acronis Recovery for Microsoft Exchange Agent is installed do the following:
- Click Start -> Run and type in secpol.msc
- Click Security Settings -> Local Policies -> User Rights Assignment;
- Right-click the Log on as a batch job policy and click Properties;
- Add the Administrator group to this policy.
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If Step 1 does not help, then on the Domain controller machine do the following:
- Go to Start -> Control Panel -> Administrative Tools -> Domain Security Policy;
- Browse down to Local Policies -> User Rights Assignment and locate the Log on as a batch job policy;
- Right-click the Log on as a batch job policy and click Properties;
- Add the Administrator group to this policy.
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On the server with Microsoft Exchange installed click Start -> Run and issue the following command:
gpupdate /force
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Restart the Acronis Agent Service:
- Click Start -> Run -> and type in services.msc
- Right-click on the Acronis Remote Agent service and click Restart.
More information
See also: