2966: Acronis Backup & Recovery 10 Cannot Connect to Acronis Linux Agent

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Operating Systems: 

Manually create the /mms directory and make sure the /tmp is not mounted with the "noexec" option

This article applies to:

  • Acronis Backup & Recovery 10 Advanced Server (Agent for Linux)
  • Acronis Backup & Recovery 10 Server for Linux (Standalone)
  • Acronis Backup & Recovery 10 Advanced Server - Virtual Edition (Agent for Linux)

Symptoms

  1. You have Acronis Linux Agent installed on a Linux machine. See Installation of Acronis Backup & Recovery 10 Agent for Linux;
  2. When trying connect to the Acronis Linux Agent from Acronis Management Console, the connection fails with the following error message:

The required service on the remote machine is not started. Start the service and retry the connection

Or

Failed to establish remote connection: Remote connections are disabled

Cause

There are several possible causes:

  • A serial key for the Standalone edition instead of the Advanced one was used to install the Acronis Agent;
  • Installation of Acronis Linux Agent did not create the /mms directory, which it needs to be running. This is a known issue;
  • Acronis Linux Agent did not automatically start;
  • The /tmp directory is mounted with the noexec option. This prevents Acronis Linux Agent from running.

Solution

(!) This has been fixed. The fix is available in the latest released build of Acronis Backup & Recovery 10.

To fix the issue without downloading the update, please do the following:

  1. Make sure you used a serial key for Acronis Backup & Recovery 10 Advanced Server and not for Acronis Backup & Recovery 10 Server for Linux (Standalone). The Standalone edition does not allow remote connection;

  2. Create the /mms directory manually:

    mkdir -p /var/lib/Acronis/mms

  3. Check that the Acronis Linux Agent and Acronis Managed Machine services are started on the machine they are installed on:

    /etc/init.d/acronis_agent status

             /etc/init.d/acronis_mms status

  4. If it is not, start them manually:

    /etc/init.d/acronis_agent start

             /etc/init.d/acronis_mms start

  5. Check that the /tmp directory shows that it is mounted without the noexec option:

    mount | grep tmp

    If it is mounted with the noexec option, remount it:

    mount -o remount,exec[device_name]/tmp

More information

See:

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