2909: Microsoft Exchange Database Cannot Be Restored from a Full Backup on Windows Small Business Server 2003

Acronis Recovery for Microsoft Exchange errors out on trying to restore Information Stores from full backup

This article applies to:

Symptoms

  1. With Acronis Recovery for Microsoft Exchange you are trying to restore a database from a full backup on Windows Small Business Server 2003;

  2. You create a Restore task with the following options enabled:

    • Restore from the last backup
    • Restore all Information stores

    All other restore options are default.

  3. The restore process fails with an error message similar to the following one:

    message="ESE adapter server raised error: Error access denied opening the restore environment file." line_tag="0x3B862FE41708B780"

Cause

Acronis Recovery for Microsoft Exchange cannot copy a critical temporary file to the database folder because write permissions are not set for the database folder. 

This issue may occur after any update of Windows Small Business Server 2003.

Solution

Before restoration of a database, you need to change security settings of the database folder:

  • Right-click on a folder with database files, and select Properties;
  • In folder properties, select Security -> Advanced;
  • In the window that opens check the Replace permission entries on all child objects with entries shown here that apply to child objects item.

More information

 

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