27521: Acronis Backup Advanced: Adding Machine to Management Server Fails with "Failed to migrate data to license server"

License server is not accessible or the license is already in use

Symptoms

Scenario A:

  1. You install Acronis Agent for Windows and provide the serial number manually;
  2. You try to add this machine to Acronis Management Server;

Scenario B:

  1. You install Acronis Agent for Windows and provide the License Server address manually;
  2. You try to add this machine to Acronis Management Server, associated with a different License Server;

In both of the above scenarios, the operation fails with the following error message:

Failed to add the machine <machine_name> to the management server

Authentication has failed.

Failed to migrate data to the license server.

Failed to obtain a license from the license server.

Cause

There are several possible causes:

  1. License Server is not accessible from the machine with Agent;
  2. License that was used to install Agent is already used;
  3. License Server associated with Acronis Management Server does not contain the same type of licenses as the original License Server which was used to install the Agent.

Solution

Check if machine with Acronis License Server is accessible from the Agent machine:

  1. Make sure that the machine with Acronis License Server is accessible from the machine with Agent: ping Acronis License Server machine by name;
  2. If ping by name is unsuccessful, ping the machine with Acronis Licenses Server by IP address;
  3. If ping by IP address is successful, the License Server should be added by IP: 
    • In Acronis Management Server, go to Actions -> Change License Server
    • Instead of machine name, enter the IP address of License Server machine;
  4. Re-add the Agent machine to Acronis Management Server.

Check if the license is already in use:

  1. On Agent, go to Help -> About and note the used license;
  2. Go to Acronis License Server and check whether the license is already assigned to a machine;
  3. If license is already assigned, select this license in the list and press Revoke;
  4. In case you have an Upgrade license, make sure that there is a valid pair of licenses that Agent can use - e.g., full license for any previous version of the product has to be available along with upgrade license;
  5. Re-add the Agent machine to Acronis Management Server.

Import the licenses from the original License Server which was used to install the Agent to the License Server associated with Acronis Management Server:

  1. Run Acronis Management Console, go to Tools -> Manage Licenses and connect to the original License Server;
  2. Click on Export licenses to XML, and save the file with licenses;
  3. In Management Console connect to Acronis Management Server, go to Licenses, click Add license and select Import keys from file;
  4. Choose the file with licenses you exported from the original License Server and import them;
  5. Re-add the Agent machine to Acronis Management Server.

More information

See also Firewall settings for Acronis products.

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