25988: Acronis Backup & Recovery 11: Backup to Tape Fails with "ID unknown. Impossible to get library using this ID"

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This article applies to:

  • Acronis Backup & Recovery 11 Advanced Server 
  • Acronis Backup & Recovery 11 Virtual Edition 
  • Acronis Backup & Recovery 11 Advanced Server SBS Edition
  • Acronis Backup & Recovery 11 Advanced Workstation

Symptoms

  1. Backup to tape fails with the following error:

    ID unknown. Impossible to get library using this ID

    OR

  2. You try to create a personal vault on tape. You select the tape device, but it is impossible to select a drive: the only available option is Not specified:

Cause

When you back up to tape directly (not via Storage Node), a personal vault is created automatically. If this vault is manually deleted, all subsequent backups to tape will fail with the above error message.

Solution

To resolve the issue please do the following:

  1. Go to Start -> Run -> services.msc. In Services window, right-click on Acronis Removable Storage Management Service and click Stop.
  2. Create a copy of ARSM database: copy the following file to a different location:
    • Windows 2003/XP: Documents And Settings\AllUsers\ApplicationData\Acronis\BackupAndRecovery\ARSM\Database\arsm.sqlite
    • Windows 2008/Vista/7: ProgramData\Acronis\BackupAndRecovery\ARSM\Database\arsm.sqlite
  3. Go to Start -> Run -> services.msc. In Services window, right-click on Acronis Removable Storage Management Service and click Start.
  4. Download invalid_location_id.zip and unzip it.
  5. Run invalid_location_id_fix.exe from the unpacked archive;
  6. If no tape vaults are created, create one.

After backup task runs fine, you can delete the copy of ARSM database that you created in Step 2.

More information

See also:

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