21636: Acronis Backup & Recovery 11: Scheduled Backup to USB Fails with "Failed to open the backup location"

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Last update: 08-04-2016

This has been fixed

This article applies to:

  • Acronis Backup & Recovery 11

Symptoms

  1. You create a scheduled backup to an external USB drive;
  2. Backup starts on schedule, but then fails with an error similar to the following one:

    Failed to open the backup location.|Additional info:

    Message: Failed to open the backup location.

    Fields: function : FindFirstFileW, filename : \\?\E:\Acronis\*|Message: Access to the file is denied.

  3. If you start the backup task manually, it runs correctly.

Cause

Batch job does not have access to external USB drive.

When the task is launched manually, Acronis Scheduler2 Service, which is responsible for launching tasks, logs in using an interactive logon type: the service logs on under the user the same account under which backup task is launched. If this account has access to the external USB, backup runs correctly.

When the task runs on schedule, Acronis Scheduler2 Service first logs on as a batch job. If logon as batch job is impossible, Acronis Scheduler2 Service will attempt to use interactive logon instead (i.e. it will log on under user that you specify when you create the task.

Solution

(!) This has been fixed. The fix is available in the latest released build of the product. See Installation of the latest update of an Acronis product.

To work around the issue without installing the latest build, add the user account under which Acronis tasks are executed  to Deny logon as batch job user right. Follow the steps below:


More information

See also Acronis Backup & Recovery 11.

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