Choose a different location or assign Local Administrator rights to Acronis Agent User
This article applies to:
- Acronis Backup & Recovery 10 Advanced Server
- Acronis Backup & Recovery 10 Advanced Server - Small Business Server Edition
- Acronis Backup & Recovery 10 Advanced Server - Virtual Edition
- Acronis Backup & Recovery 10 Advanced Workstation
Symptoms
- You connect to Acronis Management Server;
- You select a machine in the Physical machines list, right-click on it and select Backup;
- You select to save the backup to the root of a local disk on the machine (e.g. to C:\ or D:\ directly);
- You receive an error message similar to the following one:
Failed to obtain the list of local permissions
Access is denied. Check if the "Write" permission is granted for user "[Computer_name]\Acronis Agent User"
Cause
Windows does not allow Backup Operators to create, modify and delete files in root directories. To do this, Administrator rights are needed.
During Acronis Backup & Recovery 10 installation, if you select to create new accounts for Acronis services, the product creates Acronis Agent User account for running Acronis Managed Machine service. By default this account belongs to the Backup Operators group and has only Backup Operator permissions.
Solution
There are several possible workarounds:
- Do not save backups directly to root directory. Create a folder and save backups to it.
- Connect to Acronis Agent directly by using Manage Remote Machine button in Acronis Management Console (instead of connecting via Acronis Management Server):
(!) When connecting to a remote machine, specify the account with Administrator rights.
- Add Acronis Agent User to Administrators group on the machine that you are trying to back up and restart Acronis Managed Machine Service. This will give the program the necessary rights to access root directories.
More information
See also: