How to resolve the situation when Acronis Recovery for Microsoft Exchange Management Console hangs or errors when connecting to an Acronis Agent remotely
This article applies to:
For other Acronis products see:
(!) Please make sure you are familiar with Connecting to Acronis Recovery for Microsoft Exchange Agent: Known Issues .
Symptoms
Cause
Either proper credentials for connection are not specified or Acronis Agent does not have certain privileges set.
Solution
Make sure there is no Acronis True Image Echo Build 8163 or lower. If there is, please uninstall it completely (see Acronis True Image Echo Cleanup Utility ) and update to the latest build (see Downloading the Latest Build of Acronis Software );
Specify proper credentials as described in Connecting to Acronis Recovery for Microsoft Exchange Agent: Known Issues ;
On the machine where Acronis Agent is installed, depending on the operating system, do the following: Windows Server 2003
Go to Control Panel -> Administrative Tools -> Local Security Policy ;
On the Local Security Settings screen select Local Policies -> User Rights Assignment ;
Make sure that the NETWORK SERVICE user is present in the following policies:
Adjust memory quotas for a process
Replace a process level token
(!) To add the NETWORK SERVICE user you will need to do the following:
Right-click on the service and select Properties ;
Click Add User or Group ;
In the new window type in NETWORK SERVICE;
Click OK .
If the machine with Microsoft Exchange Server is part of a domain, then domain security policy will overwrite the local security policy. Please set the security policy accordingly:
If Microsoft Exchange Server is running on a machine, which is part of a domain, but is not a Domain Controller, then the default domain security settings are to be changed:
Go to Start -> All Programs -> Administrative Tools -> Domain Security Policy -> Security Settings -> Local Policies -> User Rights Assignment
Add the NETWORK SERVICE user as described above (if the user is not already there).
If Microsoft Exchange Server is running on a Domain Controller, then the default domain controller security settings are to be changed:
Go to Start -> All Programs -> Administrative Tools -> Domain Controller Security Policy -> Security Settings -> Local Policies -> User Rights Assignment
Add the NETWORK SERVICE user as described above (if the user is not already there).
Restart the Acronis Agent service:
Click Start -> Run ;
Type services.msc in the command prompt and hit Enter;
Right-click on the Acronis Remote Agent line and choose Restart in the pop-up menu.
Windows 2000 Server, Windows Server 2008
Go to Control Panel -> Administrative Tools -> Local Security Policy ;
On the Local Security Settings screen select Local Policies -> User Rights Assignment ;
Make sure that the SYSTEM user is present in the following policies:
Adjust memory quotas for a process (or increase quotas in Windows 2000)
Replace a process level token
(!) To add the SYSTEM user you will need to do the following:
Right-click on the service and select Properties ;
Click Add User or Group ;
In the new window type in SYSTEM;
Click OK .
If the machine with Microsoft Exchange Server is part of a domain, then domain security policy will overwrite the local security policy. Please set the security policy accordingly:
If Microsoft Exchange Server is running on a machine, which is part of a domain, but is not a Domain Controller, then the default domain security settings are to be changed:
Go to Start -> All Programs -> Administrative Tools -> Domain Security Policy -> Security Settings -> Local Policies -> User Rights Assignment
Add the SYSTEM user as described above (if the user is not already there).
If Microsoft Exchange Server is running on a Domain Controller, then the default domain controller security settings are to be changed:
Go to Start -> All Programs -> Administrative Tools -> Domain Controller Security Policy -> Security Settings -> Local Policies -> User Rights Assignment
Add the SYSTEM user as described above (if the user is not already there).
Restart the Acronis Agent service:
Click Start -> Run ;
Type services.msc in the command prompt and hit Enter;
Right-click on the Acronis Remote Agent line and choose Restart in the pop-up menu.
More information
To ensure domain policy doesn't override local policy, it is also recommended to add the SYSTEM and NETWORK SERVICE accounts to the default domain security policy (or any other policy applied to the Exchange server) on the primary domain controller:
Start -> All Programs -> Administrative Tools -> Domain Security Policy -> Security Settings -> Local Policies -> User Rights Assignment
You can also view the resulting effective policy in the following way:
Start -> Run -> rsop.msc -> Computer Configuration -> Windows Settings -> Security Settings -> Local Policies -> User Rights Assignment
See also Connecting to Acronis Recovery for Microsoft Exchange Agent: Known Issues .