If you are providing the correct password and Acronis True Image errors out with "The password does not match", please reinstall the product to resolve the issue
This article applies to:
- Acronis True Image 11 Home
- Acronis True Image Home 2009
- Acronis True Image Echo Server for Windows
- Acronis True Image Echo Workstation
- Acronis True Image Echo Enterprise Server
- Acronis True Image for Microsoft Windows Small Business Server
(!) The issue does not occur with the current versions of Acronis software.
Symptoms
- Using Acronis True Image you have created a password-protected backup archive;
- In Windows you put in the correct password when trying to mount, explore or restore the backup archive;
- Acronis True Image errors out with a message similar to the following one:
Cause
Certain DLL components did not install properly.
Solution
- Uninstall Acronis True Image and all its components through Add or Remove Programs (Start -> Control Panel);
- Remove the /Program Files/Common Files/Acronis folder;
- Open Windows Registry Editor (Start -> Run -> regedit) and remove the following subkey:
- Windows 32 bit: HKEY_LOCAL_MACHINE\SOFTWARE\Acronis
- Windows 64 bit: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Acronis
(!) The subkey is Acronis. Do not attempt to remove the whole registry key.
- Reboot the machine;
- Reinstall Acronis True Image.
More information
Since the issue is Windows specific, as a workaround you may restore the backup archive from Acronis Bootable Media. See Standalone Version of Acronis Software.
(!) The issue does not occur with the current versions of Acronis software.