1759: Windows Fails to Boot With "NTLDR is missing"

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Last update: 21-12-2010

Instructions on how to make Windows bootable if it reports "NTLDR is missing" after being restored with Acronis True Image

This article applies to:

  • Windows 2000
  • Windows 2000 Server
  • Windows Server 2003
  • Windows XP

    (!) There is no NTLDR in Windows Vista, Windows Server 2008, Windows 7

Symptoms

  1. You use Acronis True Image to restore an image of your operating system to a different hard disk drive or partition;
  2. After the restore Windows does not boot with the following error message:

    NTLDR is missing

Cause

  • NTLDR or Ntdetect.com files are not present on the active partition:
    • NTLDR is the boot loader for all Windows NT operating systems, including Windows 2000, Windows 2000 Server, Windows XP and Windows Server 2003
    • Ntdetect.com is responsible for detecting hardware necessary to start the operating system;
  • Boot.ini file is corrupt or points to incorrect partition

Solution

NTLDR or Ntdetect.com files are not present on the active partition

  1. Start the machine from Windows installation CD;

    (!) You may need to change the boot order in the system BIOS to let the machine boot from CD.

  2. At the Welcome to Setup screen, press R to repair the Windows installation using Recovery Console;
  3. Type the number that corresponds to the Windows installation that you want to repair, and then press Enter. E.g., type 1, and then press Enter;
  4. Type the Administrator password, and then press Enter;
  5. Type the following commands: cd ..
    dir /p
  6. Check if NTLDR and Ntdetect.com files are listed in the root of the drive. If the files are present, then please proceed to Boot.ini file is corrupt or points to incorrect partition. If these files are not present, proceed with the steps below;
  7. Type map and then press Enter;
  8. Note the drive letter that is assigned to the CD\DVD-ROM drive that contains the Windows CD;
  9. Type the following commands: copy [drive]:\i386\ntldr [letter]:\
    copy [drive]:\i386\ntdetect.com [letter]:\

    where [drive] is the drive letter of your CD\DVD-ROM drive and [letter] is a letter of the drive Windows is installed on.

    Press Enter after you issue each of the two commands.

    If you are prompted to overwrite the file, type y, and then press Enter.

  10. Reboot the machine.

Windows should be bootable now. If it is not, please proceed to Boot.ini file is corrupt or points to incorrect partition.

Boot.ini file is corrupt or points to incorrect partition

  1. Start the machine from Windows installation CD;

    (!) You may need to change the boot order in the system BIOS to let the machine boot from CD

  2. At the Welcome to Setup screen, press R to repair the Windows installation using Recovery Console;
  3. Type the Administrator password, and then press Enter;
  4. Issue the following command:

    Bootcfg /rebuild

    This command will find the existing Windows installations and add the necessary strings to boot.ini.

  5. At Enter Load identifier enter any name for the found operating system;
  6. When you are prompted for OS Load options type fastdetect and press Enter;
  7. Reboot the machine and choose the just added operating system from boot menu.

Windows should be bootable now.

More information

You can also edit the boot.ini file manually from Windows as described in the Microsoft Knowledge Base Article 289002.

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