16314: Installation Rolls Back with "Failed to grant access to the agent certificate!" in the Log

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Operating Systems:

Symptoms

  1. You are attempting to install Acronis Backup & Recovery 10 Agent for Windows or Acronis Disk Director 11 Advanced;
  2. The installation starts, but then rolls back;
  3. In the installation log you search for the Return value 3 entry (for operating systems in English) and you see the following error entries:

    (!) For complete information on how to analyze installation logs, please see Analyzing Installation Logs of Acronis Products Based on MSI Technology.

    ...
    1: MSIGEN:ManagedMachineService install::Install, res=0
    1: MSIGEN:Failed to grant access to the agent certificate!
    1: MSIGEN:MsiManagedMachineServiceInstall: exception error code 196610
    Action ended 21:50:14: InstallFinalize. Return value 3.
    ...

Cause

The Workstation service is either not started or not present on the system. This is a Windows service.

Solution

  1. Hit Start -> Run and type in services.msc
  2. Double click the Workstation service;
  3. Set the service Startup type to Automatic;
  4. Set the Service status to Started;
  5. Click OK;
  6. Restart the installation.

If the Workstation service is not present in the system, then do the following:

  1. Hit Start -> Run and type in ncpa.cpl
  2. Right click on your primary network adapter, and select Properties;
  3. Click on Properties again, check that Client for Microsoft Networks is not present in the list;
  4. Click on Install, select Client, click on Add, then select Client for Microsoft Networks and hit OK;
  5. Make sure that Workstation service is started as described above;
  6. Restart the installation.

More information

Please contact Acronis Customer Central if you have further questions or need assistance.

If this is not the rollback that you have, please see the main article about installation rollbacks: Analyzing Installation Logs of Acronis Products Based on MSI Technology.

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