16253: Acronis Backup & Recovery 10: Error in Logs "Failed to enumerate the WMI class object"

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Operating Systems: 

Make sure that Acronis Managed Machine Service runs under account that belongs to Administrators group

This article applies to:

 

  • Acronis Backup & Recovery 10 Advanced Server
  • Acronis Backup & Recovery 10 Advanced Server - Virtual Edition
  • Acronis Backup & Recovery 10 Server for Windows
  • Windows Server 2008 R2

Symptoms

  1. The operation log of Acronis Backup & Recovery 10 shows the following message:

    Failed to enumerate the WMI class object

    OR

  2. You try to connect to the Acronis Backup & Recovery 10 Agent on the local machine. Connection fails with the error:

    Failed to enumerate the WMI class object

(!) This issue is specific to Windows Server 2008 R2.

Cause

The user under which Acronis Managed Machine Service (MMS) is started is not a member of Administrators group.

Solution

Add the user under which MMS runs to domain Administrators group or run MMS under a domain Administrator account.

More information

This issue is specific to Windows Server 2008 R2. If you receive this error in different environment, the issue is not covered in this article and needs investigation. In this case please contact Acronis Customer Central.

See also Acronis Backup & Recovery 10: Do Not Run Acronis Managed Machine Service under the Local System Account.

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