14640: Acronis Recovery for Microsoft Exchange: Error Message During Incremental Backup "There is no information about the previous backup or it is invalid"

A third-party program truncates Microsoft Exchange Server logs

This article applies to:

  • Acronis Recovery for Microsoft Exchange
  • Acronis Recovery for Microsoft Exchange SBS

Symptoms

  1. You run an incremental backup of Information Store with Acronis Recovery for Microsoft Exchange;
  2. The backup job errors out with an error message similar to the following one:

    Cannot create an incremental backup of the following Microsoft Exchange storage group: 'Group1'. Reason: There is no information about the previous backup or it is invalid. Trying to create a full backup of the storage group...

    or

    Log File chain is corrupted. File 'xxxxxx.log' is missing

  3. A full backup is created instead of the incremental one.

Cause

A third party software backs up or uses Microsoft Exchange and truncates operation logs, preventing Acronis Recovery for Microsoft Exchange from identifying the modified data to back up.

When Acronis Recovery for Microsoft Exchange creates a backup, it truncates the operation logs and remembers the last transaction that was backed up. When the following incremental backup starts, the program looks for the corresponding entry in transaction logs to identify what data changed since the last backup. If a different program truncates operation logs between the two Acronis backups, the necessary entry in transaction logs is missing: in this case the program reports that there is no information about previous backup and creates a full backup instead in order to preserve the backup integrity.

(!) Backup operation will fail if there is not enough space for the full backup.

Solution

It is not recommended to use several third-party backup tools simultaneously since backup operations may conflict.

If you want to keep the third-party software for Microsoft Exchange backups together with Acronis Recovery for Microsoft Exchange, there are two possible workarounds:

  • You can ignore the error message. A full backup will be created instead of incremental one;
  • Reconfigure Acronis Recovery for Microsoft Exchange backup plan to include only full backups.

More information

See also: 

Contact Acronis Customer Central if you have any questions or need assistance.

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