12114: Acronis Backup & Recovery 10: Adding a Machine to Acronis Management Server Fails with "Failed to add the trusted service."

Last update: 30-01-2014

This is due to the lack of permissions on the account specified when adding the machine

This article applies to:

  • Acronis Backup & Recovery 10 Advanced Server
  • Acronis Backup & Recovery 10 Advanced Server - Small Business Server Edition
  • Acronis Backup & Recovery 10 Advanced Workstation
  • Acronis Backup & Recovery 10 Workstation (Standalone)
  • Acronis Backup & Recovery 10 Advanced Server - Virtual Edition

Symptoms

An attempt to add a machine to Acronis Management Server fails with an error message similar to the following one:

Failed to add the trusted service.

The specified account does not have enough privileges to establish trust relationship.

OR

Failed to add the trusted service.

The provided credentials do not have enough permissions to add the storage node.

 

Cause

There are two possible causes:

  • There are not enough permissions on the account specified when adding the machine;
  • If this is a Windows 7, Windows Vista or a Windows Server 2008 machine, and you are providing an administrator account, it is most probably not a member of a domain and has User Account Control (UAC) enabled.

Solution

  • When you specify the credentials to adding a remote machine to Acronis Management Server, the account you specify must be a member of the below two groups on the remote Acronis Agent machine:
    • Acronis Remote Users
    • Administrators
  • If you add a non-domain machine which is running Windows 7, Windows Vista or Windows Server 2008 and has UAC enabled do one of the following:
    • Disable UAC:
    • Join the machine to domain.

More information

For complete information on the required permissions and on how to add a user account to the Acronis Remote Users group see Acronis Backup & Recovery: Required User Permissions for Local and Remote Management.

 

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