Centralized managed vault creation may fail when the account running Acronis Storage Node service does not have sufficient permissions to the vault data or database location
This article applies to:
- Acronis Backup & Recovery 10 Advanced Server
- Acronis Backup & Recovery 10 Advanced Server - Small Business Server Edition
- Acronis Backup & Recovery 10 Advanced Workstation
- Acronis Backup & Recovery 10 Advanced Server - Virtual Edition
Symptoms
- In Acronis Backup & Recovery 10 Advanced, you go to the centralized vault view and try to create a new centralized managed vault;
- The vault creation fails with the following error message:
Failed to copy database file '7BAC9D1D-A6D6-4821-AAB9-E698F0E6B475_l.fdb' to directory 'D:\MyDB\
Cause
Acronis Storage Node service does not have enough privileges to create a file in the directory
Solution
As a best practice, please go to Start-Run -> services.msc and change the Acronis Storage Node service account to the administrator one (domain or local);
If setting the account to administrator does not comply with your security policies, go to the directory where the vault database is to be stored and make sure that the Acronis Storage Node account has Full Control permissions to the folder.
More information
Please contact Acronis Support if you need assistance.