11382: Acronis Backup & Recovery 10 Requires a New Tape for Every Backup if Acronis Storage Node is on Windows Server 2008

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As a workaround, install Acronis Storage Node on a different operating system

This article applies to:

  • Acronis Backup & Recovery 10 Advanced Server
  • Acronis Backup & Recovery 10 Advanced Server - Small Business Server Edition
  • Acronis Backup & Recovery 10 Advanced Server - Virtual Edition

Symptoms

  1. You have Acronis Storage Node of Acronis Backup & Recovery 10 installed on Windows Server 2008;
  2. Every new backup to a vault on tape requires a new tape.

Cause

This is an issue with the Removable Storage Manager (RSM) implementation in Windows Server 2008. Once the backup to the tape is completed and all the data is transferred there, Acronis Storage Node calls for a specific Microsoft RSM function (UpdateNtmsOmidInfo) to update the information about the used tape in the RSM database. However, this Microsoft API for some reason fails to allocate the memory to perform this operation properly, and as a result the tape is improperly marked by RSM and makes impossible any additional appending of data to it. Restore of the backup from such tape is still possible.

If you have an autoloader, a new tape will be taken automatically for every new backup.

Solution

As a possible workaround, you can install Acronis Storage Node on a different Windows operating system (e.g. Windows 2003 Server or Windows XP) - RSM modules are working properly there. You will have to move the tape device (including autoloaders) to the same machine where the Acronis Storage Node is installed.

More information

This problem is investigated by Microsoft engineers in collaboration with Acronis Development Team, but there is currently no ETA for the fix available.

See also Acronis Backup & Recovery 10 Tape Support in Windows Server 2008 R2 and Windows 7.

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