The backup plan creation of a Hyper-V virtual machine fails after updating Acronis Backup & Recovery 10 Build 11345 to Build 11639
This article applies to:
- Acronis Backup & Recovery 10 Advanced Server Virtual Edition Build 11639
Symptoms
- You have a Hyper-V host. You are backing up your virtual machines using the Acronis Agent for Hyper-V;
- You update from Acronis Backup & Recovery 10 Build 11345 to Build 11639;
- After you have updated, you attempt to create a backup plan to back up your Hyper-V virtual machines;
- The backup plan creation fails with the following error message:
Failed to process the request. An underlying layer has disconnected from the peer
- In the Application Event Log you see the following error entries:
(!) See also Microsoft TechNet Article: How to Check the Application Event Log for Errors
Name of application: mms.exe, Version: 10.0.0.11639, time-stamping: 0x4bbe4963
Name of the faulty module: VMBackupPolicyAddon.dll, Version: 10.0.0.11345, Timestamp: 0x4b10533a
Exception Code: 0xc0000005
Error offset: 0x00002bdd
ID of the faulty process: 0x17a8
Start time of the faulty application: 0x01cae079700cbab3
Path of the incorrect application: C: \ Program Files (x86) \ Acronis \ BackupAndRecovery \ mms.exe
Path of the faulty module: C: \ Program Files (x86) \ Acronis \ BackupAndRecovery \ VMBackupPolicyAddon.dll
Report ID: 94113a25-4c6d-11df-832f-f4ce46ac9276 - Regular disk and partition backup (as opposed to backing up virtual machines) works fine.
Cause
The following DLL library responsible for virtual backup failed to update:
- Windows 32 bit: \Program Files\Acronis\BackupAndRecovery\VMBackupPolicyAddon.dll
- Windows 64 bit: \Program Files (x86)\Acronis\BackupAndRecovery\VMBackupPolicyAddon.dll
If you right-click on the DLL file, you will see that it is still Build 11345 instead of Build 11639.
Solution
As a workaround, do the following:
- Stop the Acronis Managed Machine Service:
- Click on start > Right click on "My computer" > manage > Services > stop.
- Manually delete or rename the following files:
- Windows 32 bit: \Program Files\Acronis\BackupAndRecovery\VMBackupPolicyAddon.dll
- Windows 64 bit: \Program Files (x86)\Acronis\BackupAndRecovery\VMBackupPolicyAddon.dll
- Windows 32 bit: \Program Files\Acronis\BackupAndRecovery\VMBackupPolicyAddon.dll.config
- Windows 64 bit: \Program Files (x86)\Acronis\BackupAndRecovery\VMBackupPolicyAddon.dll.config
- Start the Acronis Backup & Recovery 10 installation package. Extract the Acronis Agent for Hyper-V and run a repair. This should update the file and you should be able to run backups.
More information
Please contact Acronis Support if you have further questions or need assistance.