10578: Acronis Backup & Recovery 10: Scheduled Backup to USB Fails with "Failed to open the backup location"

Last update: 23-06-2011

Scheduler service cannot access the USB device because of incorrect permissions. Deny logon as batch job to resolve the issue

This article applies to:

  • Acronis Backup & Recovery 10 Advanced Server
  • Acronis Backup & Recovery 10 Advanced Server - Virtual Edition
  • Acronis Backup & Recovery 10 Advanced Server - SBS
  • Acronis Backup & Recovery 10 Advanced Workstation
  • Acronis Backup & Recovery 10 Server for Windows
  • Acronis Backup & Recovery 10 Workstation

Symptoms

  1. You create a scheduled backup to an external USB drive;
  2. Backup starts on schedule, but then fails with an error similar to the following one:

    Failed to open the backup location.|Additional info:

    Error code: 14|Module: 64|LineInfo: 97675718d2b52d17|Fields: path : file:E:\Acronis\|Message: Failed to open the backup location.

    Error code: 20|Module: 4|LineInfo: f35f747b3b21fb14|Fields: function : FindFirstFileW, filename : \\?\E:\Acronis\*|Message: Access to the file is denied.

  3. If you start the backup task manually, it runs correctly.

Cause

Batch job does not have access to external USB drive.

When the task is launched manually, Acronis Scheduler2 Service, which is responsible for launching tasks, logs in using an interactive logon type: the service logs on under the user the same account under which backup task is launched. If this account has access to the external USB, backup runs correctly.

When the task runs on schedule, Acronis Scheduler2 Service first logs on as a batch job. If logon as batch job is impossible, Acronis Scheduler2 Service will attempt to use interactive logon instead (i.e. it will log on under user that you specify when you create the task; see Acronis Backup & Recovery 10: Specifying Task Credentials).

Solution

Add the user account under which Acronis tasks are executed  to Deny logon as batch job user right.


More information

Please contact Acronis Support if you need assistance.

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