10472: Installation of Acronis Backup & Recovery 10 Build 11639 Fails if the Acronis Services Are Running under User@Domain

Last update: 07-09-2010

This has been fixed

This article applies to:

  • Acronis Backup & Recovery 10 Advanced Server
  • Acronis Backup & Recovery 10 Server for Windows (Standalone)
  • Acronis Backup & Recovery 10 Advanced Server - Small Business Server Edition
  • Acronis Backup & Recovery 10 Advanced Workstation
  • Acronis Backup & Recovery 10 Workstation (Standalone)
  • Acronis Backup & Recovery 10 Advanced Server - Virtual Edition

Symptoms

  1. You are installing Acronis Backup & Recovery 10 Build 11639 components over an older build;
  2. The installation rolls back with an error entry in the log similar to the following one:

    1: MSIGEN:GrantUserPrivileges: Failed to grant priviledge 'SeServiceLogonRight' to user 'dc\user@domain.com' with error code '1780'

    (!) For information on how to create an installation log, please see Creating an MS Installer Log of Acronis Software.

    (!) For information on how to analyze the installation log, please see Analyzing Installation Logs of Acronis Products Based on MSI Technology.

Cause

Acronis services from an older build of the product are running on the machines under user account in the User@Domain format:

Solution

(!) This has been fixed and the fix is available in the latest build of the product. See Installation of the latest update of an Acronis product.

To work around the issue without installing the latest build, see below.

  1. Before installing Acronis Backup & Recovery 10 Build 11639, set all Acronis services to run under user account in the DOMAIN\user format:

    Acronis Backup & Recovery 10 Advanced Acronis Backup & Recovery 10 Standalone
    Acronis Managed Machine Service
    Acronis Management Server Service
    Acronis Storage Node Service

    Acronis Managed Machine Service

    To make the services run under DOMAIN\user (instead of User@Domain), do the following on all the machines that you are going to update:

    • Hit Start-Run and type in services.msc

      On the Services window, locate the Acronis services and double-click on each of them;

    • Select the Log On tab, and specify the user account in the DOMAIN\user format for each Acronis service:

  2. Then restart each Acronis service:

  3. Once all the Acronis services are set to run under DOMAIN\user and restarted, reattempt the installation.

More information

This has been fixed.

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