10166: Acronis Backup & Recovery 10 Management Console Installation Hangs if There Are Products Installed with the ADVERTISE Option

Last update: 13-05-2010

As a workaround, install the Acronis Management Console from Windows command-line

This article applies to:

  • Acronis Backup & Recovery 10 Advanced Server Build 11639
  • Acronis Backup & Recovery 10 Server for Windows (Standalone) Build 11639
  • Acronis Backup & Recovery 10 Advanced Server - Small Business Server Edition Build 11639
  • Acronis Backup & Recovery 10 Advanced Workstation Build 11639
  • Acronis Backup & Recovery 10 Workstation (Standalone) Build 11639
  • Acronis Backup & Recovery 10 Advanced Server - Virtual Edition Build 11639

Symptoms

  1. You are attempting an installation of Acronis Backup & Recovery 10 Management Console;
  2. The installation starts but never finishes:

  3. At the very end of the installation log there are entries similar to the following ones:

    MSI (s) (A4!B4) [16:42:14:708]: Creating MSIHANDLE (78244) of type 790540 for thread 4532
    MSI (s) (A4!B4) [16:42:14:708]: Creating MSIHANDLE (78245) of type 790531 for thread 4532
    MSI (s) (A4!B4) [16:42:14:708]: Closing MSIHANDLE (78245) of type 790531 for thread 4532
    MSI (s) (A4!B4) [16:42:14:708]: Closing MSIHANDLE (78244) of type 790540 for thread 4532
    MSI (s) (A4!B4) [16:42:14:708]: Creating MSIHANDLE (78246) of type 790540 for thread 4532
    MSI (s) (A4!B4) [16:42:14:708]: Creating MSIHANDLE (78247) of type 790531 for thread 4532
    MSI (s) (A4!B4) [16:42:14:708]: Closing MSIHANDLE (78247) of type 790531 for thread 4532
    MSI (s) (A4!B4) [16:42:14:708]: Closing MSIHANDLE (78246) of type 790540 for thread 4532
    MSI (s) (A4!B4) [16:42:14:708]: Closing MSIHANDLE (78235) of type 790541 for thread 4532
    MSI (s) (A4!B4) [16:42:14:708]: Creating MSIHANDLE (78248) of type 790541 for thread 4532

    For information on how to create the installation log see Creating an MS Installer Log of Acronis Software.

Cause

In the system, there are products installed with the Microsoft ADVERTISE option.

See also MSDN Article: ADVERTISE Action.

Solution

As a workaround, install the Acronis Management Console from Windows command-line:

  1. Download Windows Installer 4.5 and install it;
  2. Extract the Acronis Management Console installation file from the package:

  3. Install the extracted installation file from Windows command-line (Start-Run):

    msiexec /i "c:\AcronisManagementConsole.msi" /qb

More information

See also Acronis Backup & Recovery 10 Build 11639.

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