5324: Acronis Software Fails to Start or Cannot Back Up Disks/Partitions on SUSE Linux

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Instructions on how to install the product on SUSE

This article applies to:

  • Acronis Backup & Recovery 10 Advanced Server (Agent for Linux)
  • Acronis Backup & Recovery 10 Server for Linux (Standalone)
  • Acronis Backup & Recovery 10 Advanced Server - Small Business Server Edition (Agent for Linux)
  • Acronis Backup & Recovery 10 Advanced Server - Virtual Edition (Agent for Linux)
  • Acronis True Image Echo Enterprise Server (Agent for Linux)
  • Acronis True Image Echo Server for Linux
  • Acronis True Image Echo Virtual Edition
  • Acronis True Image Echo for MS Windows SBS

Symptoms

  1. You install the product on SUSE Linux;
  2. The product either does not show disks or partitions as available for backup or fails to start with an error message similar to the following one:

    unable to initialize snapapi module

Cause

Default SUSE setup does not allow unsupported modules.

Solution

  1. Find out what type and version of the kernel is running:

    # uname -a

  2. Install kernel sources, headers, gcc and kernel-syms matching your running kernel:

    # zypper in kernel-syms linux-kernel-headers gcc

  3. Change the directory to the /usr/src/linux-<version> directory, where <version> corresponds to the currently running kernel version:

    # cd /usr/src/linux-<version>-obj/$(uname –i)/<Type of kernel>

  4. Prepare modversion support:

    # zcat /boot/symvers-<version>.gz > Module.symvers

  5. Configure the sources for the currently running kernel:

    # make cloneconfig

  6. Prepare the headers for compilation:

    # make modules_prepare

  7. Compile and install snapapi module:

    # dkms build -m snapapi26 -v 0.7.x
    # dkms install -m snapapi26 -v 0.7.x

    where x is the snapapi build that you can find out with the "# dkms status" command;

  8. Allow for unsupported module:

    Edit the file /etc/modprobe.d/unsupported-modules/ and replace the line:

    "allow_unsupported_modules 0"

    with:

    "allow_unsupported_modules 1"

More information

Feel free to contact Acronis Customer Central if you have further questions or need additional information.

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