
Delete the Acronis Managed Machine Service (MMS) logs and Acronis Agent backup policies to resolve the issue
This article applies to:
- Acronis Backup & Recovery 10 Advanced Server
- Acronis Backup & Recovery 10 Advanced Server - Small Business Server Edition
- Acronis Backup & Recovery 10 Advanced Workstation
- Acronis Backup & Recovery 10 Advanced Server - Virtual Edition
Symptoms
- You are trying to add a new machine to Acronis Management Server;
- The operation hangs on Adding the machine...:

- At the same time, on the machine where the Acronis Agent is installed and which you are trying to add to the Acronis Management Server, the MMS.exe process starts consuming CPU and memory.
Cause
There is a considerable amount of the MMS service logs on the machine where the Agent is installed.
When trying to add the Acronis Agent to the Acronis Management Server, it tries to process all the logs and add the information to its database.
Solution
Adding the machine to the Acronis Management Server should now work fine.
More information
This is a rare case when the logs may grow because of some failing tasks generating numerous events. The behavior has been improved in the latest updates of Acronis Backup & Recovery 10 by introducing retention rules on the overall size of logs.
See also Acronis Backup & Recovery 10: Acronis Storage Node Is Unresponsive Due to Excessive Logs.