Adding a machine to the Acronis Management Server fails with "The machine has already been registered". However the machine is not in the Acronis Management Server
This article applies to:
- Acronis Backup & Recovery 10 Advanced Server
- Acronis Backup & Recovery 10 Advanced Server - Small Business Server Edition
- Acronis Backup & Recovery 10 Advanced Workstation
- Acronis Backup & Recovery 10 Advanced Server - Virtual Edition
(!) If the issue is with adding a cloned machine, see Acronis Backup & Recovery 10: Adding a Cloned Machine to Acronis Management Server Fails with "The machine has been already registered".
Symptoms
- You are adding an Acronis Agent to the Acronis Management Server;
- The operation is interrupted due to various reasons (power or network connection loss, you cancel the operation in progress, etc);
- When trying to re-add the Acronis Agent to the Acronis Management Server you receive the following error message:
The machine has already been registered

Cause
Adding the Acronis Agent to the Acronis Management Server was interrupted and did not complete successfully. Because of this, the Acronis Agent was not added to the Acronis SQL instance correctly.
The attempt to re-add the Acronis Agent failed because of the previous leftovers in the Microsoft SQL database.
Solution
(!) The script below needs to be executed under Administrator account on the machine which is running the Acronis Management Server and the Acronis SQL instance. You do not need to run it on the machine with the Acronis Agent.
Manually remove the ghost copy of the Acronis Agent from the Acronis SQL instance via a VBS script:
Deleting by machine name
- Download the script ZIP file and extract the VBS script inside it to your C:\ root folder;
- Open Windows Command Line (Start-Run -> cmd);
- Navigate to C:\ and issue the following command:
cscript /nologo delete_machine_by_name.vbs [Machine Name]

where [Machine Name] is the name of the machine that fails to be added.
(!) Notes on the machine name:
- In non-domain environment simply use the machine name;
- In domain environment use the full computer name. For example:
- MyPC.Mydomain.local
- MyPC.Mydomain.com
- The machine will then be deleted from the Acronis SQL instance:

Readd the machine to the Acronis Management Server.
Deleting by machine ID
If you do not know the full name of the machine, you can remove it by its Globally Unique Identifier (GUID):
- Find out the machine's GUID:
- On the machine where the Acronis Agent is installed, open Windows Registry (Start-Run -> regedit);
- Navigate to the following key:
Windows 32-bit: HKEY_LOCAL_MACHINE\SOFTWARE\Acronis\BackupAndRecovery\Settings\MachineManager
Windows 64-bit: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Acronis\BackupAndRecovery\Settings\MachineManager
Readd the machine to the Acronis Management Server.
More information
Feel free to contact Acronis Customer Central if you need assistance.
See also All Machines Are Grayed Out in Acronis Management Server after Updating to Acronis Backup & Recovery 10 Build 11105.