
Add the NETWORK SERVICE user to security policies to solve the issue
This article applies to:
For other Acronis products see:
Symptoms
Acronis Recovery for MS SQL Server Management Console hangs when you are trying to connect to an Acronis Agent.
Cause
Acronis Agent does not have enough privileges to allow the connection.
Solution
- On the machine where Acronis Agent is installed, do the following:
- Go to Control Panel -> Administrative Tools -> Local Security Policy;
- On the Local Security Settings screen select Local Policies -> User Rights Assignment;
- Make sure that the NETWORK SERVICE user is present in the following policies:
- Adjust memory quotas for a process (or increase quotas in Windows 2000)
- Replace a process level token


(!) To add the NETWORK SERVICE user you will need to do the following:
- Right-click on the service and select Properties;
- Click Add User or Group;
- In the new window type in NETWORK SERVICE;
- Click OK.
- If Microsoft SQL Server is running on a Domain Controller, then the default domain controller security settings are to be changed:
- Go to Start -> All Programs -> Administrative Tools -> Domain Controller Security Policy -> Security Settings -> Local Policies -> User Rights Assignment
- Add the NETWORK SERVICE user as described above (if the user is not already there).
- Restart the Acronis Agent service:
- Click Start -> Run;
- Type services.msc in the command prompt and hit Enter;
- Right-click on the Acronis Remote Agent line and choose Restart in the pop-up menu.
More information
It is also recommended to add the NETWORK SERVICE user to the default domain security policy on the primary domain controller:
- Start -> All Programs -> Administrative Tools -> Domain Security Policy -> Security Settings -> Local Policies -> User Rights Assignment
You can also view the resulting effective policy in the following way:
- Start -> Run -> rsop.msc -> Computer Configuration -> Windows Settings -> Security Settings -> Local Policies -> User Rights Assignment